TurnKey Linux Virtual Appliance Library

MediaWiki 1.14 package available

Sun, 2009/03/08 - 22:43

We have just finished successfully testing the Debian mediawiki 1.14.0-1 package on the 2009.02 release, and have updated our package archive to include it.

MediaWiki 1.14 is a new upstream release that is not considered a security critical release, so those interested in upgrading should do so manually:

apt-get update
apt-get install mediawiki

Note: This upgrade requires the following manual modifications to be performed after installation.

1. Reconfigure the MediaWiki extensions location (why?)

ln -sf /usr/local/lib/mediawiki/extensions /usr/share/mediawiki/extensions

2. The FCKeditor extension is not compatible with MediaWiki 1.14, so it must either be updated manually or disabled in /etc/mediawiki/extensions.php