TurnKey Linux Virtual Appliance Library

Webshell works with Chrome but not Firefox correctly (no - dashes)

L. Arnold's picture

On my Laptop and a desktop both (XP) I am finding I need to go to Chrome to use Webshell.  I can't type a "-" (dash) on Firefox within the webshell.

Has anyone else had this issue?  Thoughts on how to rectify.  I hate running two browsers.

Jeremy's picture

Sounds like no one else has had this experience.

Did it come good? Did you test clearing cache, cookies, etc? Have you tried it from any other machines (and/or OS)?

Personally I rarely ever use it (I much prefer to use SSH from Linux commandline, or PuTTY if from Windows) but on the odd occasion it can be handy. I've never noticed the issue on the odd occasion that I've used it, but not sure if it's just that I've been lucky (don't use XP anymore, don't use Webshell much, mostly use Chrome if I do...)

L. Arnold's picture

Still the problem. XP, Win 7 etc

I use Firefox for nearly everything.  Unfortunately I need to switch to Chrome if I want WebShell as most commands have dashes "-" in them.  Dashes do not project through from Firefox Webshell.  They do in Webmin so I think it is a problem in Webshell.

I will explore PuTTY.   The only time I am on the Command Line in Linux is when I am on the Console and I hate messing with that.

I would certainly like WebShell to work from either Browser.

thanks for the comment.

:)

Jeremy's picture

Thanks for posting a bug

I updated it last night with a bit more info for the TKL devs. And meant to post back here... Anyway it is a known upstream bug (in Shell-in-a-box/WebShell).

The current workarounds are to use the '-' key on the numpad (assuming you are using a full size keyboard) or use a different web browser...

L. Arnold's picture

Thank you for the update..

I am on a small laptop often, but I will keep the Num Pad in mind.  There is some sense in using Chrome for Shell work anyway.  I tend to have lots of Tabs open in Firefox but a short set in Chrome only.

Very cool, in Squeeze WebShell you can now actually Paste from Browser (which I couldn't do before)...  This is helpful for entering longer commands (and as I am often doing, copying from some how to into the shell)...  Could't do that w/ Lucid WebShell.  I'm yet to be a Putty guy.

Jeremy's picture

I suggest you give PuTTY a go

Part of the reason I used PuTTY instead of the WebShell is because you couldn't paste to the WebShell (although it sounds like you now can!). PuTTY is still pretty cool though I think, selecting text within PuTTY automatically copies it and right-click pastes whatever is in the clipboard.

Same problem here

I have the same problem with Shell in a box on Debian on my Raspberry Pi and Firefox. On Google Chrome it works fine so it's probably a Firefox issue.

I can't use Putty because my proxy at work is blocking almost everything but web protocols. That's why I'm using Shell in a box and it's working really good.

Jeremy thanks for the advice, I have a keyboard with the numeric pad and the "-" there woks! :D

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)