TurnKey Linux Virtual Appliance Library

How do I access the webmin management interface? (SOLVED)

Please pardon my nubiwness....

I looked through the docs, maybe not close enough? please point me to the corret doc/page?

or

is webmin part of the LAMP installation?

If so, how do I access it? I don't see anything in var/www

if not, how do I install it? is there a wget command or something to use?

Thanks for your help

John

Alon Swartz's picture

Webmin is included in all appliances

You will notice when the appliance has booted, you are presented with the Configuration Console explaining the different ways to access the appliance over the network (ie. Webmin =~ Admin Console).
http://www.turnkeylinux.org/files/images/screenshots/confconsole1.png

Just point your browser to https://appliance_ip:10000 and log in with user 'root' (default password is blank).

If you have any other questions, just ask - thats what the forums are for.

accessing webmin after installation

having already installed to the hard drive, and booted from the hard drive, I don't receive the configuration console. It just boots to the command prompt. I do get the standard "It Works!" at http://10.9.214.96 and I can login via SSH at 10.9.214.96 butI don't get a response at https://10.9.214.96:1000 Thanks John
Alon Swartz's picture

it shouldn't matter...

The configuration console "should" be launched no matter if the system is installed or running live.

Webmin is listening on port 10000 not 1000, so give this a try: https://10.9.214.96:10000

Is it possible that you are using the old version of lamp (which doesn't have the configuration console or webmin)? The latest version is turnkey-lamp-2008.10.17-hardy-x86.

no dice...

Firefox can't establish a connection to the server at 10.9.214.96:10000. The image I've got is: turnkey-lamp-2008.09.02-hardy-x86.iso I'll go download the latest one & see what happens. Thanks John
Liraz Siri's picture

There's your problem...

The version you are using is the initial launch release in September, which didn't yet include the configuration console or web management interface.

Note that our news release regarding the usability improvements is from October.

Alon Swartz's picture

Yep, thats the problem

The configuration console and web management interface were introduced in the latest release, along with some other goodies... - you can see the release notes here: http://www.turnkeylinux.org/appliances/lamp/releasenotes

If you come across any other issues, give us a shout!

Webmin password

I signed the Turnkey service today and installed Magento on amazon ec2. The mysql password was generated but not the webmin! I can not access webmin. Neither the ssh terminal!

Please help me.

 

Jeremy's picture

If you launched via the Hub

Then you would have been given the opportunity to set a root password (otherwise a random one would've been generated). The root password is what you use for logging into Webmin and SSH.

If you haven't got any data in there yet then I'd just destory your current instance and start a fresh one via the Hub. If you do have data, then you may be able to find the random password by looking through the console output (from when the EC2 instance was started). Another option (if you have data in) may be to do a backup via TKLBAM and restore that to a new instance.

Password

Thanks Jeremy I just destroy the instance and created a new one. Now everything is OK!

Problem between IE and Webmin since 10-2012

After Microsoft's Patch IE will connect to Webmin 'server' running in SSL mode on the default port 10000 . It simply gives the typical error as if the host didn't even exist rather than nagging about the self-signed Cert like it used to do.

Microsoft issue KB2661254 : Update for minimum certificate key length (min. length:1024) see http://support.microsoft.com/?kbid=2661254 cause IE can't access webmin
the webmin initial self ssl key is 512 bytes.
 
Solution: Use Chrome or Firefox and login in to Webmin go to webmin configuration ->SSL Encryption->Self-Signed Certificate.  Create a new SSL key and certificate for your Webmin server , the RSA key select default (2048), and make sure 'Use new key immediately' is checked.
You can now access using IE.
Jeremy's picture

Thanks for this post.

I have lodged a bug report.

Alon Swartz's picture

I just looked into this and I'm puzzled...

The default bit-length in the inithook [1] which regenerates the SSL certificate on firstboot is set to 1024. I tested regenerating the certificate as well as increasing the bit-length, and I don't see any keygen issues.

$ openssl s_client -showcerts -connect localhost:12321 |grep 1024
Server public key is 1024 bit

The OP mentioned connecting to webmin on port 10000, but that hasn't been the default webmin port for years. Was webmin installed directly from upstream and using the default cert?

Any more info that you can provide would be great. Can someone reproduce/confirm the issue?

[1] /usr/lib/inithooks/firstboot.d/15regen-sslcert

Jeremy's picture

Ahhh....

Perhaps I was being a little over-zealous that day?!? 

Perhaps they had Webmin from somewhere else and just came across TKL in their travels and posted the issue?

Looks like maybe I jumped on it too quick (without asking enough questions...) I notice that I marked it as confirmed and normally wouldn't do that unless I either had come across a second report of the bug or could reproduce it myself, but I don't recall testing it...

My bad I think... Sorry!

Alon Swartz's picture

No problem

I marked the bug report as invalid for now, and we'll re-open if new information is submitted.

Cant login

Cant login to mineos turnkey on 192.168.0.35(my ip)/admin

The username/password is invalid please help!

Webmin login

How will i login in webmin through my private key ....

 

Pls help me 

 

 

Jeremy's picture

AFAIK you need a password to use Webmin

Although I may be wrong...

Workarounds may be to manually set a root user password (which IIRC will mean that you can also login to your server with this same password - defeating the security advantages of using keys). Or I think that you can manually set (reset?) a Webmin user account apssword from the commandline. Although TBH I have never done it nor know how to... Hopefully google might turn up an answer for you...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)