TurnKey Linux Virtual Appliance Library

LAPP Appliance Issues

Hello everyone.

This is the third TurnKey Appliance that I have tried and I must say that these are VERY nice appliances.

Im having trouble with getting apt-get to work correctly.  I am trying to install MySQL on the LAPP appliance along with PHPMYADMIN and PHPPGADMIN and am having trouble getting apt-get to work correctly.

When I type apt-get install mysql-server i get


root@lapp:/etc/apt/sources.list.d# apt-get install mysql-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package mysql-server

I have went into /etc/apt/sources.list.d  then the file source.list and removed all of the comment tags and still no dice.  When I run apt-get update I get the following:

Err http://archive.turnkeylinux.org hardy-security Release.gpg
  Could not resolve 'archive.turnkeylinux.org'
Err http://archive.turnkeylinux.org hardy Release.gpg
  Could not resolve 'archive.turnkeylinux.org'
Err http://archive.ubuntu.com hardy-security Release.gpg
  Could not resolve 'archive.ubuntu.com'
Err http://archive.ubuntu.com hardy Release.gpg
  Could not resolve 'archive.ubuntu.com'
Err http://archive.ubuntu.com hardy-updates Release.gpg
  Could not resolve 'archive.ubuntu.com'
Err http://archive.ubuntu.com hardy-backports Release.gpg
  Could not resolve 'archive.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://archive.turnkeylinux.org/ubuntu/dists/hardy-security/Release.gpg  Could not resolve 'archive.turnkeylinux.org'

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-security/Release.gpg  Could not resolve 'archive.ubuntu.com'

W: Failed to fetch http://archive.turnkeylinux.org/ubuntu/dists/hardy/Release.gpg  Could not resolve 'archive.turnkeylinux.org'

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy/Release.gpg  Could not resolve 'archive.ubuntu.com'

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-updates/Release.gpg  Could not resolve 'archive.ubuntu.com'

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy-backports/Release.gpg  Could not resolve 'archive.ubuntu.com'

W: Some index files failed to download, they have been ignored, or old ones used instead.
W: You may want to run apt-get update to correct these problems

I tried to see if iptables is blocking it from going out but it is not installed. 

Can someone please let me know what im doing wrong?
 

Alon Swartz's picture

networking configuration

It seems to me like a networking configuration issue, nothing to do with APT. If you could provide a little more information about your setup, it would be easier to help.
ifconfig -a
route -n
cat /etc/resolv.conf

ping www.google.com
ping 209.85.135.147
Did you configure networking or was it done automatically via DHCP?

BTW, if you are using a virual machine, make sure it has access to the hosts network via NAT or bridged networking.

Thanks for the quick reply.

Thanks for the quick reply. Here is a printout of all of the information that you asked for. The networking was done via DHCP. Right now im SSH into the machine but it doesnt seem to go out to a network location.
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:02:a5:b1:eb:0f
          inet addr:192.168.10.110  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::202:a5ff:feb1:eb0f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15795 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9354 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2168785 (2.0 MB)  TX bytes:7663926 (7.3 MB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:67475 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67475 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:33855829 (32.2 MB)  TX bytes:33855829 (32.2 MB)
route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
cat /etc/resolv.conf
nameserver 127.0.0.1
domain home
nameserver 192.117.33.17

UPDATE
Ran update GW command and now route-n shows
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.10.1    0.0.0.0         UG    0      0        0 eth0
Alon Swartz's picture

DNS configuration

My best guess is your /etc/resolv.conf is misconfigured, for a couple of reasons:

1. Have you setup a local dns configuration? (ie. 127.0.0.1)
2. The nameserver configured doesn't seem to be a nameserver, or atleast isn't accepting my traffic.
$ htping -f -p 53 192.117.33.17; echo $?
htping: No route to host
1

$ host -a turnkeylinux.org 192.117.33.17
Nameserver 192.117.33.17.static.012.net.il not responding
turnkeylinux.org ANY record not found at 192.117.33.17.static.012.net.il, try again
A quick search revealed that you should be using {pdns,sdn}.012.net.il, so update your /etc/resolv.conf to contain:
212.117.129.3
212.117.128.6
This should solve your problem, unless ofcourse you also have routing problems...

To see if there was anything

To see if there was anything that I did wrong, I went ahead and reinstalled the LAPP server (since it only takes a few minutes) :)

Here is what I found. During the install, DHCP is done automatically. When I go into the admin tool and configure StaticIP, it removes the GatewayIP address. I then have to go back in and manually put in the GatewayIP.

If I reboot the machine, and go back into the StaticIP setup, the GatewayIP address is removed.

I think there may be a bug in the LAPP install or either I have a bad disc.

As of now it is working and my setup looks the same once I run what you asked me to the first time.
route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.10.1    0.0.0.0         UG    0      0        0 eth0
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:02:a5:b1:eb:0f
          inet addr:192.168.10.110  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::202:a5ff:feb1:eb0f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:28839 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15608 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:42566092 (40.5 MB)  TX bytes:1097739 (1.0 MB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:70 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:34953 (34.1 KB)  TX bytes:34953 (34.1 KB)
Thanks a lot for all of your help with this. I really appreciate it.
Liraz Siri's picture

I think we nailed this bug

Sorry for taking so long to get back to you. You seem to be describing a bug in the confconsole which the recent 2009.02 release should have fixed. Could you try again and see if we've solved your problem?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)