TurnKey Linux Virtual Appliance Library

PCMCIA network Adapter-wlan0 not found

I am trying to setup LAMP stack on an old laptop.  I tested the linksys wireless card in Xubuntu 8.04.  While running the Xubuntu live CD I edited the interfaces file to match my wireless essid and wep key.  Worked great.

 

I tried the same thing with Turnkey LAMP, but I get error wlan0 not found.  It does not show up in ifconfig.  It does show the adapter in lscpi.

 

Was the pcmcia support trimmed? 

 

I don't even get the power light on the card.

 

Liraz Siri's picture

No support for wireless or pcmcia by default

We build our appliances by starting with a core of essential packages and then adding the minimum packages required for the application (e.g., LAMP) to run. We don't trim any particular version of Ubuntu.

We believe the main use case for software appliances is running in Virtual Machines and stationary desktop/server type hardware, not laptop hardware, which is why the TurnKey core currently doesn't include support for pcmcia or wireless out of the box, and of course we also don't test for that scenario.

You may still be able to run an appliance on laptop type hardware with a wifi card but you'll have to experiment a bit to get it to work. We use the same kernel as Xubuntu so that shouldn't be a problem, but some userland tools are probably missing:

Try this:

apt-get update
apt-get install pcmciautils wireless-tools
If you get it to work, please share your experience on the forum for the benefit of other users who might share your circumstances.

Good luck!

wireless-support not found

Thanks for the quick reply. I ran the recommended code. Here are the results.

root@lamp:~# apt-get install pcmciautils wireless-support
Reading package lists... Done
Building dependency tree
Reading state information... Done
pcmciautils is already the newest version.
E: Couldn't find package wireless-support
root@lamp:~# apt-search wireless
-bash: apt-search: command not found


root@lamp:~# apt-cache search wireless
pcmciautils - PCMCIA utilities for Linux 2.6


Any other suggestions where to progress. I had to temporarily add an NIC, since the laptop only had a modem. Nothing is ever easy, but if it is difficult you must be doing it wrong.
Liraz Siri's picture

Typo in the original post

Sorry there was a typo in the original post. I corrected it. wireless-support is supposed to be wireless-tools.

Also, you have to `apt-get update' first to update your local package database. I added that to the post.

Thanks got wireless-tools still no joy.

I found the wireless-tools via Ubuntu docs. I still have no joy. The card is listed in lspci, but it will not power on. It is not found via ifconfig. I wonder if my other post is related or indicating a botched install. Nothing is ever easy, but if it is difficult you must be doing it wrong.
Liraz Siri's picture

try installing the restricted kernel modules

Hmmm... your wireless card may not be supported by a non-restricted driver. Try installing the restricted drivers:
apt-get install linux-restricted-modules
You may need to add the `restricted' component to your apt sources. For example, on my workstation I enable the main, universe, restricted and multiverse components:
$ cat /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu hardy main
deb http://archive.ubuntu.com/ubuntu hardy universe
deb http://archive.ubuntu.com/ubuntu hardy restricted
deb http://archive.ubuntu.com/ubuntu hardy multiverse

Tell me if this helps...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)