TurnKey Linux Virtual Appliance Library

PHP MyAdmin and other local IP not working

Hi Everyone,

I need  to empty the existing database of my Drupal appliance, freshly installed (no content yet).

That is when I realised that accesses to PhpMyadmin, and other webmins, https did not connect. Only the site.

Also, I do not see where to place the modules, themes and things Drupal has to offer. I do not see any drupal file on my system by the way. Is it a trick of the .iso image disk ? (you can figure how much of a newby I am ;-)

Tx for your help.

Pier

Liraz Siri's picture

Being a newbie is tough, read a lot and experiment

Hang in there Pier. Being a newbie can be tough. Let me assure you that TurnKey Drupal works just fine and you are probably just overlooking something.

The appliances work out of the box, but if you want to do the more advanced things such as install modules you'll need a better understanding of how things work, and you'll get there by reading through the documentation (e.g., Ubuntu, Drupal) and doing a lot of experimenting. Eventually with a bit of trial and error you should get there.

Watch out, Drupal is a very powerful system that has a serious learning curve and can be rather nasty to newbies.

Anyhow, I'll help you out on the first question, but in general you'll need to learn how to be more self sufficient because our resources are very limited and we can't afford to do too much hand holding for newbies if we want to have time to continue to do other things such as develop new appliances.

You can install Drupal modules by extracting them to /etc/drupal5/sites/all/modules and then enabling them in the Drupal administration panel. You might also need to fix access control privileges for that module in the Drupal administration panel.

Good luck!

Connection failure was a Firefox security issue

Hi there Liraz, This morning, maybe because Firefox upgraded automatically (3.0.8), I had a warning that access to PhpMyadmin and Webmin were certificate issues. I confirmed the "sites" were safe and I had access to the login pages of both applications. Then I had to figure out what the ID + Pwd were. I had #1045 messages denying access to the DB for instance. I found after some trials and errors that ID + Pwd were admin and root without passwords.
This is to say that yesterdays pb are solved; I post so that it may help others and as a follow up to your answer. I realize that you are 2 guys on this project in addition to your regular work. So your work is really appreciated. Best Pier
Liraz Siri's picture

Yeah, Firefox 3 doesn't like self signed certificates

Unfortunately, Firefox 3 doesn't like self signed certificates and there is not much we can do about that, aside from trying to improve the documentation to warn people about it.

Regarding the authentication username/passwords to Drupal they are documented in the appliance page under the headline "Default credentials" so you shouldn't have needed to find that by trial and error. You probably missed that.

Anyhow, thanks for the feedback and encouragement!

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)