TurnKey Linux Virtual Appliance Library

ftp failure with Joomla appliance

Hello Guys,

I've just installed the Joomla appliance (turnkey-joomla-2009.06-hardy-x86.iso, on a Vista machine) and started experiencing with Joomla.

I had a problem uploading images and other files from the local machine into the virtual box, but this was solved after browsing the support forums - I chowned /usr/share/joomla15 to www-data (with -R flag).

However, I'm now trying unsuccessfully to ftp to the new virtual box (using Core FTP LE client); I get the "Can't establish connection" error.

I'm trying to ftp with the 'root' user, specifying /usr/share/joomla15 as the remote start folder.

I also tried using 'www-data' as user (after enabling it to login via webmin) - same error.

ping works both ways.

Can anyone help?

Many thanks,

Ronen

 

 

Liraz Siri's picture

Appliances only support secure FTP

We should have fixed the file ownership issue. Will have to take another look at that. Thanks for pointing it out.

Regarding issues with file transfer, I'll venture and guess you're probably trying to connect to the appliance using FTP rather than SFTP. According to their web site Core FTP LE supports both.

We don't support FTP because it's highly insecure to pass around your passwords unencrypted on the network. Also, FTP servers are complex and historically there have been many remote exploitation vulnerabilities associated with them. Better not to go there.

Issue solved

Hi Liraz, You're right. I switched to SFTP (had to set on the flag for "Use Putty compatible SFTP" in my client) and was able to connect. Thanks a lot for the prompt reply! Ronen

Mostly the same as above

I have had the same trouble but as of yet I have been unable to use ftp all together running filezilla on my Windows 7 RC machine (Maybe use different FTP Client?). I am also, same as above, running Turnkey Joomla in VirtualBox and I am also using (if it makes a diff) Avira virus scanner personal. The rest of the interface seems to be working just fine *smiles*. Thanks Tim

Mostly the same as above

Hi Tim, What worked for me (using "Core FTP LE" client) was using SFTP protocol as Liraz suggested, and setting on the flag "Use Putty compatible SFTP" in the ftp client. Ronen

Got it

It's kinda funny, I spent the next few hours on and off (after I posted) playing with with Turnkey (Linux side of it) and got to know the machine fairly well. I figured out that if I added a new user (in CLI) I can use that and whats more I am now recalling that I should be able to limit access to a user over sftp by modifying the ssh.conf and/or sshd.conf file(s). This would put a user into their default directory with no access to the upper directories. Anyway... to make this story *fairly* short, I got it figured out with Core and Filezilla. Thanks much Tim

sftp

For what it's worth, I forgot to use a Ubuntu account, I was using an account created inside Joomla. Now I just have to rummage around to find the correct Joomla directory. Using Filezilla.

Tom

Alon Swartz's picture

Joomla location

Depending on what you are looking for, these might be of interest:

/etc/joomla15

/usr/share/joomla15

/var/lib/joomla15

file location

It's /usr/share/joomla15

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)