TurnKey Linux Virtual Appliance Library

mysql root password (SOLVED)

homer15's picture

 on each turnkey appliance i use, i've noticed that the mysql root password is never the one i set in the installation.  i don't know what it is, but it's not any of the passwords listed on the info pages for the appliance.  i've just gotten used to resetting the password through the command line and flushing the permissions.  i wasn't sure if this is just happening to me (probably not), or if you guys were even aware of the problem.

Alon Swartz's picture

This sounds like an awful bug...

This sounds like an awful bug, but with all of our testing prior to releasing the appliances setting the mysql root password seems to work. Are you sure you are not confusing the system root password with the mysql root password?

What appliance(s) + version did you test?
Did you install via the boot prompt or the live system?

I'll take another look to see if I can confirm the bug. Could you submit a bug report on the bug tracker.

Has anyone else come across this issue?

homer15's picture

quick testing

 i just did a quick test with all the mysql appliances i have.  

turnkey-lamp-2009.02-hardy-x86.iso

turnkey-mediawiki-2009.03-hardy-x86.iso

turnkey-phpbb-2009.03-hardy-x86.iso

turnkey-wordpress-2009.03-hardy-x86.iso

 

i installed all of these from the boot menu.  with a simple password of "turnkey" it works fine.  with a complex password like "p@$Sw0rD", it allows me to login to webmin but it says "Login failed : Incorrect administration username or password" for accessing mysql server.  

i'll open a bug report for this right now.

Liraz Siri's picture

I suspect shell interpolation

Looking at the di-live script that sets the MySQL password I think I know what's wrong: the SQL update command is being passed through to the mysql cli command through the shell, which interpolates certain characters in the password as a variable name "MY$PASS". The fix is easy, just escape the characters (e.g., mkarg() function in commands Python library)
Alon Swartz's picture

Fix commited

This issue has been fixed and will be included in all appliance releases from now on.
For more information, refer to the bug report.

Glad im not the only one

I was banging my head thinking I was doing something wrong.  I too am having this problem.  With the LAMP and Joomla appliances.  I am new to Linux and I was just about to build my own Ubuntu JeOS LAMP appliance because I could not get these to work.  I'm not sure what is meant by (e.g., mkarg() function in commands Python library).  Can you please explain.

Alon Swartz's picture

See the bug report for more information

See the bug report for more information (ie. the bug has been fixed and the fix will be included in all upcoming appliances).

In the meanwhile, just use a password for mysql/postgres that does not include special characters just as "$" (you can change the password later ofcourse).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)