TurnKey Linux Virtual Appliance Library

Turnkey Linux fails to acquire IP addresses

Hi all,

After I boot up App Engine Turnkey Linux from VirtualBox, configuration condole says: "No interfaces are configured". In VM's network settings I have tried all adapter types - none work.

What can cause it and how is it possible to make it work?

Bests,

Alex

Jeremy's picture

Hmm

I don't use VirtualBox as my virtual environment now days (since I've found something that suits my purpose better), but I'm pretty sure the network conncection you need to use is the bridged one.

Is it working for other OSs or is it just TKL? Assuming its not working for any OS then perhaps try uninstalling and reinstalling VBox? Then just try using it as a live cd (in VBox) and see if you can get that working.

Some other options for assistance could be checking on the VirtualBox wiki or searching and/or posting on the VirtualBox forums. Ubuntu Forums and/or Ubuntu Documentation may be a good source of info TKL is a customised version of Ubuntu 8.04.2.

Problem solved

Thanks for your reply, it came out that I had to assign astatic IP to the VM since my main PC was disconnected from Internet. Earlier, when my physical box was connected to ISP an IP was leased to the VM by ISP's DHCP.

No Interfaces are configured

Ive been running the MediaWiki turneky for some time without issues.  I have moved it around from one virtualization server to another before without issues.  Sometime after a move of that type today, on startup, I am now getting "No Interfaces are configured" in the turnkey ui.

At this point, the only choice it <ok>, which then takes me to a menu which includes only two options.

 

The top of the screen - this last time - says "eth13 configuration".  It always has the same two choices, DHCP and STATIC configurations options. Selecting DHCP returns:"error" and then a few lines down. "eth13".  Thats all thats on the screen.  <ok> is the only choice possible.

Each time this process happens, that number increments.  Next time it will be going on about eth14.

Selecting 'back' enough times returns me to the main menu gui, which has one line on it only.  "No interfaces are confugured"

I have created a completely new virtuallization for it, and I know that the VS is not trying to use anything other than eth0.  But the turnkey doesnt think it has one.

This seems like an operating system issue, something has gone wonky in Ubuntu and I have no idea where to begin.  Naturally, there are no backups so Id like to be aable to get this puppy on the network again somehow.

 

Jeremy's picture

What environment are you using?

Have you tried any of the solutions/workarounds available here? Such as this or this (there's also more info on that thread) or this?

Let us know how you go and we'll take it from there.

Nice Catch!

I had tried several of the suggestions - but not seen this one.  That did the trick.  Thank you for all the great stuff you release, and for the help. 

(Its running under MS Virtual Server 2005 R2, and soon under Server 2008 Hyper V)

No interfaces are configured!

Hi! 

I got a simillar problem with my virtual box, ubuntu turnkey settup.

I followed this tutorial to set it up for local PHP development.

http://www.packtpub.com/article/develop-php-web-applications-netbeans-virtualbox-turnkey-lamp-appliance

I do however get the no interfaces are configured message for eth0 and I get an error when searching for the IP which ends with "failed to bring up eth0"

I have selected the bridge network option.

I have tried enter a static IP and use this url from netBeans to connect: http://192.168.1.1/turnkeylamp/

Q1: According to the tutorial I should get a IP automatically! Why dont I?

Q2: If I need to use static IP address which should I use?

Thank you for your time! 

 

Jeremy's picture

Have you had it running at all?

If not I'd suspect its something with VirtualBox rather than TKL. Especially assuming you installed from ISO (as per the tutorial).

1. You will only get an IP automatically if the PC/VM has network connectivity to a DHCP server (eg router).

2. I would add 10 to the last digit of your PC's IP (find that here: System>>Administration>>Network Tools - adjust the drop-down to the interface you're using), and ping it. For example if your PC IP is 192.168.1.10 then ping 192.168.1.20. If no response then that is probably a good IP.

Double check all your settings in VirtualBox, especially those relating to the network adaptor. Perhaps try changing it?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)