TurnKey Linux Virtual Appliance Library

LAMP: Using MySQL GUI to connect to virtual machine

 I have the hardy heron LAMP appliance running in VirtualBox for development, with the network set to bridged.

I can connect to the virtual server just fine via SSH, http, and log into phpMyAdmin as root.

However, I have the MySQL GUI tools installed on my host (Win XP) and can't get them to connect. I can ping the server from them just fine. I tried port 12322 and that didn't work either. Windows firewall is disabled.

Are their other credentials besides root that I should be using to access MySQL this way?

Thanks.

Alon Swartz's picture

MySQL is bound to localhost by default

By commenting out the bind-address in the MySQL configuration, it will bind to all interfaces.
sed -i "s/^bind-address/#bind-address/" /etc/mysql/my.cnf
You will also need to configure the mysql root account to be able to connect from any (or a specific) host. An alternative is to create a new user with the required privileges. See this post for more information. Don't forget to restart mysql after your changes.

Hope the above helps.

 Well, I went to webmin ->

 Well, I went to webmin -> mysql to edit the root account.

All I changed was the host option, to 'any'.

Now the root account for MySQL can log in, but can't do anything. Not even change it's password. I tried through phpMyAdmin as well.

I keep getting this error:

Access denied for user ''@'localhost' to database 'mysql'

I think webmin may have a bug.

You should be able to connect

You should be able to connect using SQLYog, or Navicat..


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)