TurnKey Linux Virtual Appliance Library

Changing file permissions

I was trying to change permission in LAMP appliance I have installed but it didn't work. Hmm, any clues?

Thanks.

leow 

Alon Swartz's picture

more information required

Could you provide more information as to what you are trying to accomplish, and what is "not working".

Changing permissions - read,

Changing permissions - read, write etc.

I thought I have already written it in my first post included it in the title as well? That is what I was trying to accomplish..It is not a must, but I tested it in another server (where I was able to change permission in server) - so the appliance here doesn't allow me to do that?

 


Alon Swartz's picture

Sorry, but I still don't understand...

Sorry, but I still don't understand what permissions you are referring to. File permissions? Web server access permissions? MySQL access permissions...

Again, the more information you can provide the easier it will be to help.

Sorry, my wrong. I should be more specific.

It is this: When I need to create new folders in /www I can do it from an ftp I have connected. I would like to change / restrict it so that I can't do that, except only when I want to change it manually using command line whenever I work on transferring files.

It kinda makes me think I have a little more control.. that's all. Other than that, your appliance LAMP is really awesome. I am satisfied and happy with that already..


Alon Swartz's picture

A couple of tips...

Firstly, I think you meant /var/www and not /www.

Secondly, you should really be using SFTP (most ftp clients support it, and it is much more secure than FTP with regards to the traffic, ie. not sending your password in clear text).

If you are using FTP though, then you need to configure your ftp server accordingly. Depending on which one you are using, it is done differently. If you are using SFTP, then regular unix permissions should do, just connect with a different user who doesn't have permissions for more top level directories.

Hope this helps...

I think I used SFTP, Alon.. and I have tried regular unix

I have tried regular unix permissions, it didn't work - I thought it was bugs or maybe it was made so it is easy for users to use without changing permissions? another server I am using allow me to do that. 


Liraz Siri's picture

Not a bug, but a gap in understanding

Let me assure you, Unix permissions in your appliance are working just fine. There's probably just a gap in your understand of how that is supposed to work. I recommend you read up on Unix permissions and experiment a bit more until you figure it out.

I have tried to -W in /var/www but it is still +W

If I could do that in a server in its var/www but not in my appliance I have installed, then I really need to experiment more - I know a webserver and a server has a lot of differences, but can you shed some lights here?

Thanks, Liraz *How are you?

:) 


Liraz Siri's picture

I don't understand what the issue is

Hi Leow,

Wish I could be more helpful, but you haven't done a good job of describing what the problem is. You don't provide enough information, such as for example, the commands you executed, the output you received compared with what you expected, etc.

I recommend you study the Ubuntu community tutorial on file permissions to make sure you aren't missing anything. Good luck!

I am able to change the file permission in an SFTP client

..By clicking on the file/folder property to disallow write for "all" groups. But it still allows me to create/delete any files in it..

And yes, I have gone through the link you have provided, and tried almost most of the ways and guess what; the permissions alteration "do not" work.

Liraz, since you have assured me, could you please check it yourself, and see if it is working for you? and post the solution?

It is not I am not posting codes/commands, the web server seems to be a little not reactive to permission types - by appearance it has changed its value in the window property - but the actual permissions do not change. (so is by using command line) no error messages will be displayed.


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)