TurnKey Linux Virtual Appliance Library

After adding rules to webmin, turnkey is inacessible

hello all:

I set up a VM (vm server 1.0.9) using the latest turnkey drupal6 ISO, and all was well... Once configured the networking, popped onto the Firewall module and began entering rules... you know, the kind that makes sense i.e. source is from a certain CIDR network, to a certain dport... DUH!

Well, after entering the rules and hitting the activate/apply rules button all went to hell.

rebooted the VM, still same issue.

on console logged in as root, did an iptables -L, saw all my rules properly populated. Thought, maybe I goofed, so I did an iptables --flush, verified NO RULES were active, yet I still cannot get to the box

Can anyone help me please? How does one via commandline go about resetting the webmin back to out-of-box state?

--Russ

Further diagnosis has

Further diagnosis has revealed that I did enter the rules wrong, however I cannot work around webmin's hold on the system?!

What else is there besides flushing iptables?! Can someone help me here please? How do I reset webmin? How do I override webmins' firewall config?

Any help would be much appreciated!

Thank you,


Jeremy's picture

As I understand it Webmin is

As I understand it Webmin is merely a web based front-end. Everything you can do from inside Webmin you can do at the terminal. Having said that, what you can do to fix your problem is beyond me sorry. You sound like you have a pretty good idea of what you're up to so good luck. Hopefully you have anything important backed up so worst case you can start again!?

Hey JedMeister: Indeed I had

Hey JedMeister:

Indeed I had to end up starting from scratch... *sigh* I honestly don't know how this is possible, but I effectively locked myself out of the admin console by entering the wrong rules via the network config interface via webmin.

I backtracked and traced everything, and could NOT undo my rules. weird...

In any event, I've made a mental note of: "don't goof up on webmin as it seems to be irrecoverable!"

Thanks,


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)