TurnKey Linux Virtual Appliance Library

OpenBravo network connect to PostgreSQL server

Hi, 

I cant connect to postgre server, on the network with pgadminIII ?

Can anyone help with some idea ?

Liraz Siri's picture

PostgreSQL bound to localhost by default

By default we configure appliances not to allow external connections to the database for security reasons. You'll need to change the PostgreSQL configuration to allow that if you want to connect with an external client.

Thank you Liraz for info, i

Thank you Liraz for info,

i will try to play with postgres config files to allow '*'  connections

not only localhost .. i think that would be enough .. 

 

.kp

 .k.p.

Alon Swartz's picture

Configure PostgreSQL to listen/accept remote connections

This might help...

Configure postgres to listen for remote connections

CONF=/etc/postgresql/8.3/main/postgresql.conf
sed -i "s/#listen_addresses = 'localhost'/listen_addresses = '*'/" $CONF

Configure postgres to accept remote connections

# configure postgres to accept remote connections
cat >> /etc/postgresql/8.3/main/pg_hba.conf <<EOF
# Accept all IPv4 connections - CHANGE THIS!!!
host    all         all         0.0.0.0/0             md5
EOF

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)