TurnKey Linux Virtual Appliance Library

Multiple Wordpress installs with ONE Wordpress Turnkey appliance

 Hello,

I am a newbee here.

Can ONE  turnkey appliance be used to run, in this case, multiple WP installs ? 

Thanks

Liraz Siri's picture

Yes but it requires some tweaking

Since WordPress supports multi-blogging and TurnKey Wordpress is (under the hood) a pretty standard installation of WordPress on Ubuntu you should be able to set that up with a bit of tweaking.

I haven't tried that myself though but the WordPress wiki has a page about installing multiple blogs.

Same question...

I'm new to Linux and TurnKey and just started testing the TurnKey WordPress system.  I have tried following the directions using the supplied link but I think I need to change something in Apache but don't know what.

I have created new databases and directories for additional blogs as well as created the virtual hosts.  However when attempting to access the second wordpress blog Apache sends the request for my second domain to the original installation used for my first domain.

Any ideas on what I shoudl check or change?  Any guidance for us newbees would be much appreciated!

One thing I wasn't sure about was when creating the virtual host do I create a new file under the virtual servers directory or add the setting to the existing wordpress file in etc/apache2/sites-available/wordpress.  I don't know if that is what is causing my problem or if the defaul site is re-directing everything to the original installation.

Thanks!

httpd.conf

I'm not sure if you've done this, but you may need to alter your httpd.conf file (as per http://www.no-ip.com/support/guides/web_servers/using_apache_virtual_hosts.html )

I haven't done anything with

I haven't done anything with the httpd.conf file.  Mine appears to be blank at the moment.  I'm new to all of this, but from what I could tell when using webmin to create new virtual servers, it was creating files in the sites-available directory instead of appending to httpd.conf.  I just figured that the turnkey guys designed it this way and chose not to use the httpd.conf file for a good reason.  I'll take another look at that httpd file and see if I can use it.  Thanks for the help.  I'll post back if I figure it out.

httpd.conf vs sites-available

When creating the virtual host it actually gives you the option to store the new settings in the httpd.conf file or in it's own file in the sites-available dierctory.  I assume this is strictly preference, but by NOT putting it in the httpd.conf file, in my opinion, makes it easier to manage.  I have a site with a few subdomains so I chose to add those config settings to the main .conf file of the site in the sites-available directory so everything is all in one nice and tidy file without having to scroll through all the standard settings.  Now, why your httpd.conf file is blank is another story.  Maybe you are in the wrong directory??  If I remember correctly it's not in the standard location and somewhere else.  You can look at the module config for apache in Webmin and that will tell you exactly where the .conf file is located.


Jeremy's picture

It comes down to personal preference

And personally I prefer to make separate .conf files in the /etc/apache2/sites-available folder. That way different sites can be enabled/disabled with the 'a2ensite <site-name>' / 'a2dissite <site-name>' commands. It also means that the settings for each site are clearly separated. But that's just my preference.

As for the httpd.conf file being empty, AFAIK that is expected in Debain/Ubuntu as by default the main Apache2 config file is /etc/apache2/apache2.conf instead. IIRC httpd.conf file still exists but is not used in a default clean install (but perhaps is populated when Webmin is used?) Despite this, putting settings in the httpd.conf file will still work as if you scroll through the apache2,conf you will see that it is called (as well as the contents of /etc/apache2/sites-enabled and /etc/apache2/mods-enabled).

PS just realised that this post is from ages ago... Obviously missed it! Oh well...

I had the same problem of the

I had the same problem of the request going to the initial domain.

Here's what I did that seems to work.

1. Copy the wordpress files from the stock installation to a sub directory.  Say you wanted a site to be accessed as www.yourdomain.com/site2, then copy all the files in the Turnkey WordPress appliance wordpress directory to wordpress/site2.

2. Edit wordpress/site2/wp-config.php, (the one in the subdirectory) to do 2 things:

First comment out the 2 lines:

define('WP_SITEURL', 'http://'.$_SERVER['HTTP_HOST']);

define('WP_HOME', 'http://'.$_SERVER['HTTP_HOST']);
 
These are what seem to be sending you back to the original wordpress install.
 
Second, change the table prefix ($table_prefix) to something else:
 
$table_prefix = 'site2_';
 
3. Open a browser to www.yourdomain.com/site2
 
WordPress will walk you through the install of site2, create tables for this instance in the same database using your unique table prefix.

That's it.

I did not need to change anything with Apache's configuration.

More explanation of the settings here: http://codex.wordpress.org/Editing_wp-config.php

One more thought--  Make sure

One more thought-- 

Make sure the owner and group of your wordpress/site2 and all subdirectories is www-data.

I prefer to use the multisite

I prefer to use the multisite modifications. I'm running ten blogs-- so far-- off of one set of files, and I can set up blogs for my clients on the fly. 

 

My clients cannot get access to any of the other blogs, but I can administrate them all from a single backend.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)