TurnKey Linux Virtual Appliance Library

VIRTUALBOX unable bridge connections

Yet another VIRTUALBOX question:

Tried to install LAMP under VIRTUALBOX (v 3.0.10).

It looks like installed.

But my Browser can not get connected to the LAMP ip address.

I have bridged connections at VIRTUAL BOX connections.

(Virtualbox eth adpater and XP eth adapter)

Should I assign IP addresses for the adapters

or should it be auto?

 

 

Jeremy's picture

How are you trying to connect?

Before I say too much more I need to know a bit more about your setup. Sounds like you are using XP. How are you trying to connect? I'm guessing locally (ie from the PC VirtualBox is installed on)? Where are you getting the IP address from? I'm guessing the confconsole screen in the VM (ie the window in VirtualBox with TKL running inside)?

First I'd try pinging the IP (to make sure its not a browser issue). Second I'd try selecting host only networking (and reboot the TKL appliance) and see if that works. Let us know how you go with that and we'll go from there.

Hi JedMaster After upgrading

Hi JedMeister

After upgrading my VIRTUALBOX 3.14, it has started working.

I can reach LAMP httpd from XP. Connection is configured automatically.
Virtual adapter DHCP works on 192.168.56.100
Virtual Adapter address           192 168.56.102
Turnkey LAMP automatically set 192.168.56.101

I can reach webmin with explorer from same host machine XP

1) I can not reach reach LAMP from other pc on the same network
neither on explorer nor on ping. (firewalls are down, ping works between host machines)

2) I can not ping any ip from inside LAMP. I can not connect to internet from LAMP.

is there any firewall running in the LAMP? How can I stop them?

So, I did it this way. I set

So,

I did it this way.
I set VirtualBox network adapter to Bridged connection to physical adapter.

LAMP could not get network settings automatically with this setting !!
(LAMP had got auto settings at "host only"adapter setting before)

I gave a static IP as in LAN network.
Then LAMP became visible on the network.

I had to give also a route command to access internet too,

 

Jeremy's picture

So you have it working now?

Sounds like you've got it working. I suspect you may not have a DHCP server running on your network. That would explain why your VM didn't work properly until you set a static IP. A DHCP server is what will give new machines on a LAN an IP address and also tell it where the internet gateway can be found (ie it does automatically what you've done manually).

Bridged connection in Untagle

I using Red Hat version 5 and I installed Virtual Box 3.2. Through that Virutal box  I installed UNTAGLE firewall on it. I have two card both are seen in the Untangle network. Other pc not communicate with this UNTANGLE SERVER SOFRWARE FIREWALL.

Please help me I read all of comments but Bridged connection how to i do'nt know. Thanking you everyone.

Jeremy's picture

This project (TKL) isn't related to either VBox or Untangle

So I suggest that you seek help from the Untangle, VirtualBox and/or Red Hat communities for your issues.

Having said that the settings for running Untangle in VBox 3.2 should be the same as TKL so feel free to have a search through the forums or documentation here.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)