TurnKey Linux Virtual Appliance Library

Problem running Configure in TWiki

I just installed the new TWiki appliance behind a firewall at work. I need to turn off the email verification feature as I won't be able to access anything from behind the firewall.

I assume that this is done in the Configure section of the Admin Tools but when I select this, I am repeatedly prompted for Login/Pass. The AdminUser login works as a site login but I can't access Configure with it.

This is an out-of-the-box install with no customizations. Not much I can change if I can't access Configure.

Has anyone else run into this?

TWiki support forum

I recommend to ask in the Support forum on twiki.org, http://twiki.org/cgi-bin/view/Support/WebHome

Liraz Siri's picture

We'll look into it

Bill thanks for reporting this. If we can reproduce this issue on our end then hopefully we can issue a workaround and a fix which will go into the next version.

Upstream support ticket

This question is handled upstream at http://twiki.org/cgi-bin/view/Support/SID-00643 

M Ganter's picture

This is what came back: The

This is what came back:

The topic 'SID-00643 ' you are trying to access does not exist, yet.

:(

Alon Swartz's picture

Misconfiguration in apache.conf

Thanks for reporting this, it turns out to be a misconfiguration in the apache configuration. You can either comment out the configure section as Peter mentioned, so you can access it without a authenticating, or update /etc/twiki/apache.conf
old:    Require user TWikiGuest
new:    Require user AdminUser
This fix will be included in all future versions of the TWiki appliance.
BTW, disabling email verification is specified here:
Security Setup -> Security Registration -> {Register}{NeedVerification}
I hope this solves your issue.
M Ganter's picture

Yes! It IS the Apache config

Yes!

It IS the Apache config problem.     After making the suggested change and restarting Apache, I could run TWiki Configure.

It gives two warnings - one for localhost and one for email root@localhost.

After updating both and saving the Conguration, it appears to work.

Thanks!

Alon Swartz's picture

Thanks. Added to todo list

I've added the warnings you mentioned to my todo list for when we release an updated version.

 It's /etc/twiki/apache.conf

 It's /etc/twiki/apache.conf

Alon Swartz's picture

Thanks for catching the typo...

Thanks for catching the typo, I updated the above post.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)