TurnKey Linux Virtual Appliance Library

Get error 404 - Component not found in Joomla Appliance, with a SAML Plugin

 Hello,

I have installed the Joomla appliance VM and everyhting works well.

However, we need to make Joomla a Service Provider (SP) in a SAML federation so that the SAML Identity Provider (IdP) can authenticate users and re-direct them to Joomla in Single-Sign-On

This scenario has worked well with a regular Ubuntu VM, with a Joomla 1.5 package and the SAML plugin in Joomla.

What is happening in the Joomla appliance, I believe, it's the way Joomla is installed as a Virtual Host. When we install the SAML plugin in Joomla, the metadata created by the SAML plugin in the Joomla appliance is of the form:

http://<domain name>/joomla15/components/.../...

instead of:

 

http://<domain name>/components/.../...

So it appears as if the Joomla appliance Apache configuration is not resolving the re-directs.
 
Any suggestions? I have tried to see if in Webmin I could change parameters to the /usr/shr/joomla Virtual Host, but I don't know where to begin
 
Any hints will be appreciated

 

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)