TurnKey Linux Virtual Appliance Library

Turnkey File Server

The default limits file size to very small files.

How do I change that so I can send ideally 2 gig files? Or at least files greater than 50,000 bytes?

Jeremy's picture

A quick google revealed this

On the eXtplorer website it explains how to enable larger files. Have a look here. Please note I have not tested this so cannot confirm it works.

Let us know how you go with it because others may be interested in doing that too.

Good luck

Liraz Siri's picture

Where are you being limited?

Sorry for the late reply. Where exactly are you being limited to small file sizes? Is it within the extplorer interface as JedMeister suspects? Note that I haven't come across this problem myself. If you provide more information we could fix this when we come out with an update.

I'm stuck too..

I did a search for the ".htaccess" file and it was found in two places.

/var/www/extplorer/config/.htaccess

/var/www/extplorer/include/.htaccess

Being the linux no0b I am, I had NO idea how to open the file through the command line since the OS has no comfortably soft GUI to guide me through the list of text editors that may be installed. Deciding to move onto something more dangerous I logged into the webmin and started clicking around.  Under "Tools" I found "File Manager" and was able to locate the files, save and open them on the machine I'm on now. The only thing is, is that when either file is opened they both say the same thing.    "deny from all"     Nothing else is in the file. I'm lost. Please someone shed some light on what simple thing I'm doing wrong or where I'm supposed to be looking. Thanks in advance and keep up the great work!

 

Jeremy's picture

edit php.ini I think

I haven't tried this (as I use FTP instead) but I'm pretty sure you'll need to edit /etc/php5/cgi/php.ini

If you make a backup copy first you can't go too far wrong

cp /etc/php5/cgi/php.ini /etc/php5/cgi/php.ini.backup
nano /etc/php5/cgi/php.ini

The following may need to be edited:

  • upload_max_filesize - max total of all uploaded files
  • post_max_size - max total of all uploaded data (files+other data)
  • max_input_time - you may need to increase this

max_execution_time may need to be increased too.

There are probably other limitations too (eg in apache?) but you should be able to increase it a bit.

It's not really suiited to large files though, FTP (sftp) would be a better bet.

php.ini

Thanks for your response. Getting ready to boot the server back up and try your steps out. Took some time to try to answer my question on my own but still after googling most people said it's dependent upon where you installed everything. So I decided to write out some commands on index cards and post them around my desk so to learn more about the CLI.

Also looking more into setting it as SFTP.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)