TurnKey Linux Virtual Appliance Library

DNS won't resolve

I finally got around to setting up my TKL LAMP appliance, but nothing but IP addresses resolve.  The DNS settings reflect the correct IP addresses for the DNS (other computers - OSX and Windows - in the house use the same DNS servers just fine).  I am at a loss here.  Any suggestions or files I can show off to help pinpoint the problem?

/etc/resolv.conf

What is in your /etc/resolv.conf file?

http://UnmeteredVPS.net/tkl
Try our TurnKey Linux appliance hosting FREE!

 Here are the contents:   #

 Here are the contents:

 

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

nameserver 68.87.72.130

nameserver 68.87.77.130

 

DHCP or static IP?

Is your appliance using DHCP or a static IP?

If you are using a static IP, did you set it up using the configuration console or some other way?

http://UnmeteredVPS.net/tkl
Try our TurnKey Linux appliance hosting FREE!

It's static.  I used the

It's static.  I used the configuration console.  I tried reinstalling but still no dice.  I did some poking around and realized I can't ping anything besides localhost.

Very strange

I just set up a LAMP appliance and configured it to use a static IP and the resolv.conf looks exactly the same as yours.  It does not seem to be a problem with the appliance but something between it and the network.

http://UnmeteredVPS.net/tkl
Try our TurnKey Linux appliance hosting FREE!

Jeremy's picture

No network!

Sorry to state the bleeding obvious

Is your TKL appliance installed as a VM? If so make sure you are using bridged networking.

Also may be worth a try letting it use DHCP just to make sure its not an IP conflict or something. Or you could try just changing the IP but I think DHCP for troubleshooting is the gear - you can set it to static once you have it all working.

 

No it's not installed as a VM

No it's not installed as a VM unfortunately.  No, there's not anything between it and the gateway (it was behind a switch but we moved it to see if the switch was causing problems).  I guess I'll move it behind a router and try DHCP when I get home.  I guess I'll let y'all know if that doesn't work.

Alon Swartz's picture

Some notes about networking configuration

By default appliances are configured to use DHCP.

If you want to use a static configuration, the network is configured via the Debian-standard configuration file /etc/network/interfaces.

Note that DNS settings are also configured there (I.e., dns-nameservers parameter), not directly via /etc/resolv.conf. This allows us to better support multiple network interfaces.

Example /etc/network/interfaces configuration file:
   auto eth0
   iface eth0 inet static
       address 1.0.0.63
       netmask 255.255.255.0
       gateway 1.0.0.254
       dns-nameservers 1.0.0.1 # this is for resolvconf package hook
For additional information see the manual page:
   man interfaces
   man resolvconf 
Note that the confconsole is aware of the above configuration settings, and uses them transparently.

I hope this clears up any misunderstandings...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)