TurnKey Linux Virtual Appliance Library

Turnkey-Core :MKS error when loading console

 Hi 

I probably should be in some VMware forum with this problem, but maybe someone could help me here, as i think the problem exists inside the Core Appliance  

I have installed the Turnkey- core appliance on a remote Esxi 4.0 server. This was done by using the standalone VMWare converter and the Online VMware-Go service  

When starting the appliance with the remote VMware console I get this error:  

"Unable to connect to the MKS: Could not connect to pipe \\.\pipe\vmware-authdpipe: The system cannot find the file specified."

Is it possible that something inside the Core appliance needs to be configured for this to work.

Sorry but I am from a Windows background and new to Linux, trying to get to grips with things

 

Thanks in advance

Anca  

 

 

 

I have managed to connect to

I have managed to connect to this appliance now, so the problem seems to be in the Vmware-go  remote console, which remains dysfunctional 

thanks anyway

Anca

I still can't find a solution for this error

Hey Anca

Please tell me what steps did you take to resolve this error? as all the virtual machines in my inventor are bein disfunctional. 

Jeremy's picture

I don't use ESXi so have no idea

I did try ESXi when I first evaluated hypervisors years ago but I wasn't impressed with it and found ProxmoxVE to be a far superior product (and not crippled at all) but anyway...

I don't recall anyone else mentioning this so not sure really (and I know that there are many others that do use ESX/ESXi).

Maybe you could just try installing from ISO?

hi Jeremy

This error could be produced if a firewall exists between the virtual infrastructure client and the host where the virtual machine is running blocking the TCP 903 port. If this is the case configure your firewall to allow trafic from the vi client to the physical host on port 903.

In other cases the only way to solve this is to enable the vmauthd proxy on the service console of the host. To do that we need to edit the file /etc/vmware/config adding the following line:

vmauthd.server.alwaysProxy = “TRUE”

The file should look like this:

libdir = “/usr/lib/vmware”
authd.fullpath = “/usr/sbin/vmware-authd”
authd.client.port = “902″
vmware.fullpath = “/usr/bin/vmware”
control.fullpath = “/usr/bin/vmware-cmd”
serverd.fullpath = “/usr/sbin/vmware-serverd”
serverd.init.fullpath = “/usr/lib/vmware/serverd/init.pl”
authd.proxy.vim = “vmware-hostd:hostd-vmdb”
authd.proxy.nfc = “vmware-hostd:ha-nfc”
authd.proxy.nfcssl = “vmware-hostd:ha-nfcssl”
authd.soapServer = “TRUE”
authd.proxy.vpxa-nfc = “vmware-vpxa:vpxa-nfc”
authd.proxy.vpxa-nfcssl = “vmware-vpxa:vpxa-nfcssl”
vmauthd.server.alwaysProxy = “TRUE”

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)