TurnKey Linux Virtual Appliance Library

No Apache response after VMware tools upgrade

Joomla appliance - ESX, upgraded VMware Tools using tarball from ESX server.  Ping is good although no apache response.  Unable to login to any webadmin -anything.  Was working with VMware support to upgrade tools successfully, and they are stumped.  Any ideas?  I'd hate to have to revert back to the latest snapshot unless I absolutely need to.  Thanks!

Jeremy's picture

What have you tried?

I assume you've tried restarting the VM?

Check the ports are open (external port scan of the vm) and apache is listening (netstat internally):

netstat -nltp

Try restarting apache:

/etc/init.d/apache2 restart

If apache is having problems it should let you know (via some sort of error message). You could also try checking the apache error log (/var/log/apache2/error.log I think).

Update: troubleshooting and results

Thanks for the reply.  I have tried rebooting the VM and retstarting apache to no avail.  The response from the apache restart is:

"apache2: could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName"

Possible to set the ServerName back to its original pre-vmware tools upgrade?  DNS is configured properly in Joomla console and in zones.

Thanks for any assistance.

Jeremy's picture

Don't thnk thats the problem...

But here's a solution to the error apache gives. Open the httpd.conf file

nano /etc/apache2/httpd.conf

This file will probably be blank (it is by default), add this line at the top

ServerName localhost

and then restart apache

/etc/init.d/apache2 restart

That should stop apache complaning, but I'm pretty sure that wouldn't cause lack of connectability.

What were to results of the netstat command I suggested above? Did you do a port scan of the machine?

When you ping it, I assume that was with the dns name (rather than IP) - if not make sure it pings ok with both. Also perhaps check the IP address is what it should be - this can be done from the confconsole or with the ifconfig command.

PS Until we actually know what's wrong, I'm not sure whether removing the update will actually solve your problems. The only way to be sure would be to either try and see, or to just revert to a snapshot. If you do that, I urge you to take a snapshot of the current machine, so at your conveinience you can work out what the problem is (so you can eventually upgrade VMtools hassle free).

To be honest I'm sort surprised that installing the new VM tools made this much mess.

Maybe this will help...

Thanks for all your helpful suggestions, much appreciated.

The results of the netstat indicate 0.0.0.0 for IP addresses.  All DNS/IP config is correct. 

Interesting point -the VMware tech noticed a secondary NIC was installed after the recent tools update, and I only have the one adapter configured in the vm settings.  Is there a way to remove this unwanted interface?  Reset?

I have tried the obvious -ping host/IP are successful, retarting apache, tried removing vm adapter and reinstall to no avail.  It's like the secondary NIC is the default although the IP is assigned to the other (original).  Any ideas?

Thanks!

Jeremy's picture

Sorry about the delay getting back to you.

Could you please post your interfaces file (/etc/network/interfaces).

If you have USB passthrough then thats probably easiest to just attach the file here, otherwise you may need to run

nano /etc/network/interfaces

(or replace nano for your favourite terminal text editor) and do a screenshot of your VM window. For Windows - <Alt><Prnt Scrn> with the VM Window active then <Ctrl><V> in your favourite graphics editor to paste (you may need to resize and/or adjust quality to get a small file, which is still easy to read).

Hopefully that'll help us see whats going on.

Interface Screenshot

# UNCONFIGURED INTERFACES
# remove the above line if you edit this file

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
   address 192.168.1.201
   netmask 255.255.255.0
   gateway 192.168.1.1
   dns-nameservers 192.168.1.200

auto eth1
iface eth1 inet dhcp

Jeremy's picture

You could try setting eth1 interface as static too

Use eth0 as a template. Make sure you change the "dhcp" to "static" and double check the gateway and nameserver are correct (although I would assume they're ok).

Once done, save (<Ctrl><X> in nano) and restart networking:

/etc/init.d/networking restart

Test results - Thanks for prompt response!

*Reconfiguring network interfaces...

SIOCSIFADDR:  No such device
eth1:  ERROR while getting interface flags:  No such device
SIOCSIFNETMASK:  No such device
eth1:  ERROR while getting interface flags:  No such device
Failed to bring up eth1

Is there a way to remove/delete eth1??  Thanks!

Jeremy's picture

Hmm ok, so eth1 doesn't work...

This is a strange one for sure! As its running in a VM, it should only be getting (virtual) NICs offered to it by ESX. If ESX is offering it then one would think that it would work.

You could try to just bring eth1 down and see if that helps at all, ie

ifconfig eth1 down

It may be worth bringing them both down (same line but substitute 'eth0' for 'eth1') and then just bring one of them back up (substitute 'up' for 'down') and test. Repeat for other NIC as required.

I am unfamiliar with ESX but I would imagine that you should be able to remove/disable from there somewhere (sort of like a virtual BIOS). If possible remove both NICs offered, reboot your appliance, then re-enable one, reboot appliance, check, next one etc.

Something else that may be worth trying is simply to comment out (ie put a "#" in front of) all the lines relating to eth1 in the networking interfaces file.

Other than those I'm fast running out of ideas. If nothing here gets you headed in the right direction, then I can only think of 2 plans:

1) Create a new VM appliance and somehow migrate your data across. Don't forget to upgrade/install VMtools first!

2) See if you can get some advice from someone more experienced than myself. I would highly recommend Ubuntu Forums (as thats what TKL is basically - 8.04.3) although because there's so much activity over there, you'll probably need to be patient.

httpd.conf

Hey,  Dumb question...how could the site be working with httpd.conf empty?  Where are the default settings? 

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)