TurnKey Linux Virtual Appliance Library

Connecting to MySql from a remote machine

 I would like to connect to the Turnkey Joomla MySql Server from a remote machine.

How would I go about setting MySql to receive a tcpip connection from a remote machine on port 3306. 

 

 

Password question

This has been my biggest frustration with Turnkey Django so I'm happy to see the instructions. I usually flail around until it works with each server I set up.

To get these commands to work I changed the "$MYSQL_PASS" to my actual password. When I was done MySql seemed configured to accept connections from "root" with no password. Is that right? Or did I do something wrong again?

Problems running command

RE : http://www.turnkeylinux.org/docs/database-remote-access

When I run step 2 from the comand line shell in webmin I get this:

"bash: --execute: command not found"  ?
 

 

It seems the simplest way to

It seems the simplest way to do this is to login into Mysql server using phpMyadmin and go to the user permissions set up and set the user permission to  All privileges and Host = AnyHost .

I should have done that in the first place rather than labor over the suggested procedure

Anyway I am still confused why I was getting the "command not found" referred to in my previous post.

Yes-ish

I agree 100% re: changing the user's host - either phpMyAdmin or the MySQL module of Webmin is far easier.

I did find that in my case, I still had to run the first command from the guide (sed to add a binding) to get it to work.

It's worth noting that I'm by no means an expert and tend to muddle through with a colleciton of guides so there may be something going on that I missed

EDIT: After a little more reading, --execute shouldn't be trying to run as a command, it's a parameter passed to the mysql command.

Just to double check, the box in the guide containing the --execute command is actually 2 commands - one which sets up an alias(? not sure of correct term) which just specifies a call to mysql with a username/password and batch mode enabled.

The second command (starting $MYSQL_BATCH --execute) then does the actual insert.

 Does this help at all?


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)