TurnKey Linux Virtual Appliance Library

Problems using webmin

Hi,

I can't log into webmin - I can get the login page up, but all my login attempts fail, whether I use root with no password or root with the password I changed it to.

Note that I have never been asked to change the password for root, I did it myself.

Any ideas?

thanks

Andrew

Thanks for responding. I

Thanks for responding.

I don't think that will work, unless I've misunderstood the info.

I can log into the Turnkey VM install as root with the password I have set, but I can't log into Webmin.  These instructions show how to change the root password if I understand them correctly, but I don't seem to have a problem with that.

Could it be a network thing?

 

Regards

Andrew

Jeremy's picture

Ok, sorry bout that.

AFAIK Webmin uses the root Linux user as the default user (using the root Linux user password). At least thats how it works for me on all my TKL appliances. But I have never changed my root password from initial install and I use the ISO installs (rather than the VM ones) so the password is set at install.

On my Proxmox VE Server (Debian based) I installed Webmin and it automatically allowed my Linux root user (with the root Linux user password).

Perhaps try resetting your root Linux user password using the directions found on the post I linked to above and try again.

Tried that and it didn't make

Tried that and it didn't make any difference.  I'm wondering if it's connected to the networking problems I'm also experiencing - though I can get access to the Drupal install.  I'll sort that out first and then come back to this if necessary.

Thanks for your help

Andrew

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)