TurnKey Linux Virtual Appliance Library

how to install cfengine2 on turnkey linux domain controller appliance and manage it with webmin?

how to install cfengine2 on turnkey linux domain controller appliance and manage it with webmin?

Jeremy's picture

Seems its in the repos so pretty easy

As cfengine2 is in the Ubuntu repos it should be pretty easy to install. Looks like TKL have a pre-packaged webmin module in their repo too so hopefully that should do the trick. At the commandline (however you access it - SHH/WebShell/Webmin/etc).

apt-get update
apt-get install cfengine2 webmin-cfengine

Let us know how you go.

Error:

I have installed cfengine, but I got an error: The Configuration Engine command /usr/sbin/cfexecd on your system is version 2.2.3, but this Webmin module only supports versions 1.x . let me tell ya how I got this error, I first downloaded the .deb file from ubuntu hardy repos of cfengine2 and then when this .deb file downloaded, I accessed webmin by using my https://youripaddress:12321 url to access webmin from a webbrowser on one of my computers and I logged into webmin and I went to software packages and clicked "From uploaded file" and then uploaded my .deb file of cfengine2 from the ubuntu hardy repos and then clicked install and it said that cfengine2 was installed successfully, so I go to the cfengine webmin module and I have to change the module config because some of the paths of the cfengine2 module was not configed correctly(I used the paths from the installation page of cfengine2) and then when I clicked save, and it went back to the module main page and then I got this error: The Configuration Engine command /usr/sbin/cfexecd on your system is version 2.2.3, but this Webmin module only supports versions 1.x .

Jeremy's picture

Hmm perhaps Webmin module won't work?

But before you give up on that approach, I'd try using the latest version from Webmin, apparently that module has been updated this year - have a look here.

The Webmin Module has not be updated

The Webmin Module has not be updated, I still get this error message:


The Configuration Engine command /usr/sbin/cfexecd on your system is version 2.2.3, but this Webmin module only supports versions 1.x .

I have installed the webmin module from the link you gave me and it still gave me this error message: "The Configuration Engine command /usr/sbin/cfexecd on your system is version 2.2.3, but this Webmin module only supports versions 1.x ."

Jeremy's picture

Looks like you're out of luck then.

According to the Webmin website that plugin was "Last updated 2010-03-05 23:06:28" but obviously not to support v2.

Looks like there may not be an offically supported cfengine2 webmin plugin available. A bit of googling failed to reveal an unoficial one.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)