TurnKey Linux Virtual Appliance Library

[DC Appliance] Help

Hello.

I have installed the DC appliance on my server. After pointing my XP Testbox tot the right WINS server, I have got a annoying problem. When I type in "MYDOM" in the computername properties Domain field, it pop ups directly with the credintials field, when I fill in administrator + password, it takes a while and then: boom! The domain controller does not exist or can not be contacted. Strange is, I can ping the IP of te server, and I can ping my computers IP from the server side. But I can't ping the hostname! (PDC.local) Any ideas?

And, when Lucid 10.04 is out, can someone make an auto install script for Samba 4? I need to apply group policy's, and in 4 I can do that with RSAT.

Thanks in advance,

Sef

Codehead's picture

Domain not found

I had the same problem initially, but setting the PDC server IP as the WINS server on the client fixed it. Is there any further info on the error dialog?

On a bare metal install I got a the same 'Domain not found' message, but it was actually a username/password issue (Thanks Microsoft). I assume you're using the Samba 'Administrator'/'turnkey' user/pwd combo not 'root'/'[rootpassword]'?

As for pinging the hostname, remember, we're in NETBIOS territory, not DNS. So the servername is just PDC.


Domain not found

Actually, I don't use the appliance. I have a stand alone mini server (Atom Zxxx), that I use purely for PDC use. I have installed via the ISO, and I have set a other password then "turnkey". I am using that password.

And can somebody answer my second question?


Jeremy's picture

As I mentioned in your other topic...

Samba4-alpha8 is in the Lucid repos, so it'll be a simple case of apt-get install samba4. Config on the other hand, I have no idea about....

Domain not found and Samba 4 Tutorial

And the config is my problem... Can someone make a tuorial of it? I am a newbie in Samba.

And I still have the domain not found problem. Any helps? :)

Edit:

I have got the domain not found again, after I have typed the domain name and the logon credintials.

Looking in my log.smbd shows up this:

[2010/04/27 15:41:16, 0] nmbd/nmbd_browsesync.c:domain_master_node_status_fail(248)
domain_master_node_status_fail:
Doing a node status request to the domain master browser
for workgroup MYDOM at IP 192.168.1.70 failed.
Cannot sync browser lists.

I read somewhere that I need to delete the /var/cache/samba/wins.dat file, but it doesn't exist!

Edit 2: Found wins.dat in /var/lib/samba, deleted it and rebooted the server. No avail. Deleted both wins.dat and /var/cache/samba/browse.dat. Rebooted the server. No avail here too. I think there is some deep trouble in the settings... Any ideas?

(And yes, the WINS IP is given in the Windows IP settings, and the Samba registry tweaks are applied (try to make a XP Testbox domain member first))


Jeremy's picture

Remember Samba4 is still alpha

which adds an extra layer of complexity to your problems/troubleshooting. Being alpha software you will find:

  • it is experimental so you will be unlikely to get any support from Samba unless you are using the latest version (I think its up to alpha11?) which will involve installing from git/tar.gz rather than from a standard repo (or .deb). Even then it will most likely involve lots of work for you too.
  • very few people are using it as its not good practice to use alpha/experimental software in a production environment, so getting help from people who know all about it will probably be a struggle.
  • with any problems that arise, it may be hard to work out whether you are experiencing a bug or its just something you've done wrong.
  • the documentation is limited and I strongly doubt you will find a comprehensive tutorial available until after it is offically released (later this year or early 2011).

Having said all that, there appears to be some quite reasonable "how to" documentation on the official Samba wiki (Samba4 background info here).

If you are just testing/having a play with it and checking out what it can do etc then good luck. I would probably suggest searching/posting on the Ubuntu forums as you have a higher chance of finding someone there who is also working with Samba4 in a similar environment.

Botom line is that if you want to play with bleeding edge software be prepared for it to hurt (they don't call it bleeding edge for nothing)!

OTOH if you are looking to deploy a working Active Directory server in a production environment then I hate to say it but I think you need to bite the bullet and purchase a copy of Windows Server. You could probably still find an OEM copy of SMB2003 floating around somewhere.

No SAMBA 4

Rember I am using the original appliance here, with Sama 3... So the problems I expirience are in a stable release!


Jeremy's picture

Oh sorry I misunderstood

As you were asking about Samba4 and above you said: "Actually, I don't use the appliance." I misunderstood and thought you were trying to set up a Samba4 PDC in Ubuntu Lucid/10.04.

Have you had a look at the Quick Start Guide written by Codehead? If you still can't get it to work perhaps it may be worth starting again from scratch to ensure you have a clean start and that none of the things you have tried interfere with the setup. If there is anything you don't understand, post back here and we'll try to help.

Re installed

I re installed the server; clean settings, clean disk. Setted my domain to MYDOM and my adminpassword during setup. Added WINS entry in XP. Rebooted the server and the client. Still the domain not found error after typing my credintials...

 

Edit: And yes, I have followed the quick start guide...


What's the chances of TKL packaging Mandriva Directory Server?

I know there is a blueprint for a "network services" box but Mandriva Directory Server appears to answer most, if not all, the requirements and would surely be easier to implement.  There are instructions around for building it on Debian.

I'd be willing to contribute some $ to have something like this built.  I'm actually stunned that something like this isn't built into Ubuntu 10.04.  Surely it's time.

Cavan Kelly

Alon Swartz's picture

Building on Debian link

Could you post the Debian link?

sure... 

Cavan Kelly

or GOsa

If you'd like something that would probably scale better, there's GOsa  - https://oss.gonicus.de/labs/gosa/

Cavan Kelly

apt-get install samba4 Doesn't Work, E: Couldn't find package

When I try to use apt-get install samba4, it tells me this error:

E: Couldn't find package samba4

Here is what it says when trying to install samba4:

> apt-get install samba4
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package samba4

Please could someone tell me what I am doing wrong? can someone tell me why I can't install samba4 from apt-get install?

Jeremy's picture

What base are you using?

Samba4 is in Ubuntu since 8.10 (in the universe repo) so assuming you're using one of those then check that you have network connectivity. Also make sure you run apt-get update to update the package database prior to apt-get install. If you are trying to install it on TKL then you'll have to wait for the 10.04 based release (shouldn't be too long now).

Network Settings

Hi There

This looks like a network settings issue.

Have you altered anything on the server side Windows Networking page?

I see you have PDC.local which is different from the default.

Also on the same page, check that "Be WINS Server" is checked.

Regards

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)