TurnKey Linux Virtual Appliance Library

mysql out of memory

[ Also posted on ubuntu forum: http://ubuntuforums.org/showthread.php?t=1466264 ]

Hi

Few months ago I downloaded a Turnkey virtual appliance with Wordpress pre-installed. I used this as a VM on my laptop and configured it. Then when everything looked good, I transfered it to my hosting provider (which is the company I work for) and they put the VM on ESX and connected it to the internet.

Now I'm running into the issue that sometimes quite often and sometimes not for a week or so, the VM will hang. When looking outside of the VM you can see it is taking up all cpu resources available and on the console there is the following error message:

[1052409.181756] Out of memory: Kill process 8811 (mysqld) score 37029 or a child.
[1052409.181919] Killed process 8811 (mysqld)

Strange thing is that when looking at the VM memory usage, it uses less than 300 MB (from a VMware perspective). Only thing that I can do then is reset the VM (hard reboot).

After reboot I can see that Ubuntu (which is running in the VM) is using only 300MB out of 1024MB. 

I tarred all logfiles from /var/log and downloaded them but I don't know where to start looking for. I also did an update using:

apt-get update
apt-get upgrade
apt-get distr-upgrade

After the update all is running, but of course I have no idea how long it will run without issues. 

Can someone point me in the direction I start looking? Which logs are important. Can I monitor / log mysql memory usage? How to see which queries are giving me issues or taking up memory? Maybe it isn't mysql at all. Really don't know.

Some info:
- Linux wordpress 2.6.24-27-virtual
- Ubuntu 8.04.4 LTS
- mysql Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu (i486) using readline 5.2


Screenshot of the error:

Regards

Gabrie

Out of Memory

Did you ever find any resolution to this problem? I had the same error yesterday. I only have 256MB RAM dedicated for my VM though.

out of memory

Hi

Yes it turned out to be the memory settings of the mySQL database. The cache keeps running full. Turns out that if your system has 4GB and install mySQL, it can't handle change of memory that well. Try changing the memory back to the original size it had when you downloaded the VM.

If that doesn't work, email me at:  theg@gabe@man@gmail.com (leave out the first two @).

Gabrie

That should be the@gabe@man

That should be the@gabe@man :-)  (type in previous reply)

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)