TurnKey Linux Virtual Appliance Library

I messed up my phpmyadmin virtual host

Clint's picture

Ok, so I was working on adding some new virtual host in the Apache module through Webmin. When inadvertantly I deleted the phpmyadmin from the list.

Could someone please post the virtual host config for phpmyadmin? I am using this on the LAMP appliance.

 

Thanks

I have the same problem

Looks like since no one has given a quick answer we may have to start up another appliance and get it ourselves.

Alon Swartz's picture

The should be what you're looking for

I hope this helps...
 
 
/etc/phpmyadmin/apache.conf

<VirtualHost *:12322>
    SSLEngine on
    SSLCertificateFile /etc/ssl/certs/cert.pem
    ServerAdmin webmaster@localhost
    DocumentRoot /usr/share/phpmyadmin/
</VirtualHost>

<Directory /usr/share/phpmyadmin>
    Options Indexes FollowSymLinks
    DirectoryIndex index.php

    <Files setup.php>
        Deny from all
    </Files>

    <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_flag register_globals Off
        php_value include_path .
    </IfModule>
</Directory>


Clint's picture

Thank you, that did it.

Thank you, that did it.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)