TurnKey Linux Virtual Appliance Library

setting time keeps rolling back

I'm running TKL Core under VirtualBox. Every time I reboot the appliance the time is back to the UK time zone

The host locale and timezone is set for South Africa. I removed ntp.

Please assist me in setting the date and time so that it does not change back again.

Jeremy's picture

Install from ISO or VM image?

If ISO, check that you have removed the ISO from the VM. Otherwise it will automatically boot into the live environment rather than the installed one.

  Installed from a VM

 

Installed from a VM image.
 
Very strange behaviour, done dpkg-reconfigure tzdata and set the time zone on VM's same as the host, but every time I reboot the VM's the time is back to the original

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)