TurnKey Linux Virtual Appliance Library

php + fastcgi and internet access

Hi, first of all thank you for such a great tool like turnkey appliances :)

I'm using TK LAMP appliance and I have two questions:

- can someone point me / help me on how to change php settings to use mod_fastcgi instead of mod_php? I need this to work in a thread-safe environment for some custom php extension we're using.

- how can I grant my appliance internet access? shouldn't this be automatic?

best regards,
carlos

Jeremy's picture

Not sure about your 1st question

but from what I can see there is a Hardy/8.04 (basis of TKL) package in the multiverse repo called libapache2-mod-fastcgi which I assume would be the one your after. You also may find some useful info on the FastCGI website or in the Apache wiki.

As for your second question it depends on your setup. When you say "internet access" do you mean incoming or outgoing? Ie do you mean your appliance connecting to the net say to get updates, or do you mean others contacting your LAMP appliance from the internet to view the hosted web pages? Also is your appliance running on bare metal or in a VM? How does your appliance & network connect to the internet? Do you have some sort of NAT router and/or firewall setup?

JedMeister, thanks for your

JedMeister, thanks for your reply.

My first question was referring to php and the way it is installed/executed within the apache environment (whether mod_php or mod_fastcgi). I thought there was a way of changing this using webmin - using the info you provided and other tutorials I had found earlier will take me more time to learn and figure out exactly what I'm doing.

As for the internet question: my appliance is running inside virtualbox and can be reached from the host network. Outbound traffic is limited to my host network, I cannot reach the internet from my appliance (to get updates, for example).

--
carlos

Jeremy's picture

Sorry I wasn't much help with your 1st q!

Hopefully someone with more knowledge will be able to help you out. You could also try on the Webmin mailing list or Webmin SourceForge forums (although it looks like pretty much the same question was asked a year ago and no reponse). Perhaps you are out of luck?

From memory (long time since I used VirtualBox) under default settings outgoing connection 'should' just work. Assuming you do not have a firewall (either on your host system or on your network - add an exception if you are) then check that you are not using "host only networking" for your VM.

JedMeister, Question 2

JedMeister,

Question 2 solved - I had host only activated :) The links you provided for question 1, although not solving it directly will, eventually, lead me in the right direction

Thanks again,
Carlos

Jeremy's picture

Good news!

Glad I could be of asistance :)

Good info

Hello! eadedde interesting eadedde site!

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)