TurnKey Linux Virtual Appliance Library

FileServer and Port conflicts

OK, I've been digging and digging and finally have to admit I'm stumped...

I have a copy of the fileserver appliance up and running, but need to change the port # of it since I already have port 80 being forwarded to another appliance running Confluence (an awesome program that would make a great addition to your appliances).. 

I've spent hours trying to figure out how to go about changing the fileserver to default to port # 456 (just a random port I chose)..  I've searched through your forums and on google, and I'm at my wits end! 

Any help would be greatly appreciated! 

Details:

- Netgear Router WNR834B
- Running on latest version of Virtual Box on latest version of 32 bit Ubuntu
- Downloaded version: turnkey-fileserver-2009.10-2-hardy-x86 using default setting in VirtualBox

Thanks!
Reggie
 

Jeremy's picture

I assume you mean the Extplorer (WebUI) for the Fileserver?

Probably the easiest way to go would be to use your router's port forwarding capabilities here. (I just did a real quick google and it seems that your router is capable although I didn't check the details). Then you can forward incoming connections on port 456 (or whatever) to port 80 on your fileserver. VirtualBox also has NAT capabilities but doing it through your router is probably easier

Not having much luck

From what I've been able to find out, the router will only allow one IP to use port 80.  If I try to set more than one, I get the following error:

Failure

 
Port conflict with other service.
 
This page will automatically return to the previous page in a few seconds...

 

I'm at a lost of how to have another port# automatically forward to port 80 on the I.P. of the file server. 

I would welcome any hints on what I can do to resolve this..

 

Thanks!
Reggie
 


Jeremy's picture

I've just had a further look at your router's docs

and it seems that I misled you. Sorry about that. While it does do port forwarding it looks like you are only able to define the incoming port and can't customise the outgoing one. That's a pity cause thats an easy way to do what you want.

So the options left to you are doing what I suggested but with NAT in VirtualBox. Read about it in the VirtualBox User Manual (direct link to relevant section here).

But here's another thought: What about using https? Unless you are also using https for something else that's an easy way to go. Try forwarding port 443 to your appliance and use https:// instead of http://

Your original plan is still an option but requires adjusting the listening port of the webserver serving Extplorer (which I'm not 100% sure what TKL devs used, I'd guess possibly lighttpd but can't confirm at this stage).

Router

My router/modem, a real low baller from Linksys, prevents me from serving on port 80. I have solved this by changing to port of my server to 8080, and forwarding that port from the Linksys.

Maybe another option is setting port 8080 to serve on the router, and then map 8080 to port 80 on your server (via fixed ip address)?

I really don't know if I'm being any help here, but I am dumping what I've got with the hope it can be helpful.


Using Port 443

Thanks for the help!

I decided to just use the HTTPS/Port 443 option to get around this problem.

I looked into changing the port using VirtualBox, but I'm very much of a newbie at this and mucking about at the command prompt in Ubuntu to change settings seemed a bit intimidating..

I'll probably end up needing to do that one of these days if I roll out any more Turnkey appliances.. Thinking about trying out ZenCart, so I imagine I'll run into the exact same issues with that..

Love to see changing the port # added to the "Configure appliance Networking" menu one of these days!

Thanks again!

Reggie


Changing default appliance port

Hi there,

I have been playing around with few of Turnkey appliances (and loving it!). In my case I have two virtual machines running, one with Fileserver and the other one with gallery appliance (planning on adding a third). Separately they work great. But the default setup uses port443 for both (Port80 is also being used by host OS ). In order to run both at the same time, I need to change the port on one. Is it matter of going into default-ssl under /etc/apache2/... and changing the ports.conf or is there a more straight forward method of doing so?

Manny

Re: Changing default appliance port

Ok, so it was as easy as changing settings for the lamp appliance in the config files. It was even easier using the webmin console. I kind of feel silly asking the question now. I setup the webdav for a new virtual host and now I just have to get webdav to work with windows7 (client), which I think looks for a certificate from the client side. I'm sure it is in some settings. 

Great work in making these appliances. These are exactly what I was looking for. Lightweight and with all the potential....

Manny

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)