TurnKey Linux Virtual Appliance Library

Mediawiki 2009.6 Out of Memory: kill process # score # or a child

Christian Peper's picture

Last week I started getting "out of memory" errors in my 2009.6 mediawiki (MW) VM. After doing an apt-get upgrade, things would work fine for a while until the console would be soiled with error such as (see screenshot):

Out of memory: kill process 5023 (apache2) score 225331 or a child
Killed process 5023 (apache2)
Out of memory: kill process 4497 (mysqld) scrore 32182 or a child
Killed process 4497 (mysqld)

Firefox just shows a blank page, Chrome reports an error: 

Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error.

So i started comparing this MW to another very similar MW installation based off of the same 2009.6 ISO. I didn't have any problems there, but I also hadn't run the Linux upgrade yet. I compared LocalSettings, AdminSettings, made dumpbackups and mysqldump exports, just in case. But nothing I'd find would pinpoint the problem. So I upgraded the second MW as well. And this also led to failures on that VM. Clearly, something is not right in both installation when doing an upgrade. Apt-get must forget to correct something. 

Both php5 and mysql5 were upgraded, as can be seen from the update log. Nothing was changed (by me) in any config files right before/after the update. Both VMs have 512MB but I bumped the first one up to 1GB to see if that helped. Same difference. 

Even though the console shows the Out of memory error, both mysql.err and mysql.log in /var/log are empty.

Any ideas?

Christian Peper's picture

apt-get logs

Going thru the apt-get logs to see what was changed and adapted, I noticed that the VM upgraded itself from apache 2.2.8 to 2.2.9 and deposited to cfg files in /etc/apache2 that were marked as new but not merged with my existing cfg files:

  1. /etc/apache2/ports.conf
  2. /etc/apache2/apache2.conf

So I checked out the new files but discovered nothing shocking, except the following mention:

 

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>
This points to a configuration change between the previously bundled apache2 and the latest one through apt-get. However, it does not strike me as something that can cause major out of memory errors.
Apache2, apt, dpkg nor mysql losg show anything useful. I am at a dead end now... frown

Christian Peper's picture

Caused by a manual MySQL root pwd change?

Could it be caused by a manual change of the MySQL root passwd and it not being in sync with the secret keys that are mentioned in the janadmin thread?

Just a hunch... if so, how do I reset the secret keys along with the MySQL root pwd?


Same problem here

Im having the same issues.  It started happening after a Oracle VirtualBox update and updates to the MediaWiki appliance.  Any luck with the password reset?

Christian Peper's picture

problem after update

Yes indeed. For me it happened after an update of the Linux box, outside of the web tools or anything. I used the command line as root.


Hey Christian,    Do you

Hey Christian,

   Do you think it might be related to SQL or PHP? I dont know much about any of this but I can access webmin and the terminal from the browser but PHPmyAdmin does not work.

Let me know if you had any luck fixing this issue.

Alright, suspecting it is a

Alright, suspecting it is a PHP issue I turned on safe-mode for PHP (I dont know what that means but it Windows it usually helps : ) When I try to load the mediawiki website now I get the following:

 

Warning: require_once() [function.require-once]: SAFE MODE Restriction in effect. The script whose uid is 0 is not allowed to access /usr/share/mediawiki/extensions/awc/forums/awc_forum.php owned by uid 999 in /etc/mediawiki/extensions.php on line 61

Warning: require_once(/usr/share/mediawiki/extensions/awc/forums/awc_forum.php) [function.require-once]: failed to open stream: No such file or directory in /etc/mediawiki/extensions.php on line 61

Fatal error: require_once() [function.require]: Failed opening required '/usr/share/mediawiki/extensions/awc/forums/awc_forum.php' (include_path='/usr/share/mediawiki:/usr/share/mediawiki/includes:/usr/share/mediawiki/languages:.:/usr/share/php:/usr/share/pear') in /etc/mediawiki/extensions.php on line 61

 

Does this help solve the problem at all?

Did you get this resolved?

Were you able to find a fix for this issue?

Not really a solution.  I

Not really a solution.  I downloaded the latest version of the mediawiki appliance, installed it in a new VM and exported the wiki from the new to the old VM.

Christian Peper's picture

no fix, reinstall and restore content

No, I was unable to fix this. Reinstalled the latest TKMW and restored content from previous one.


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)