TurnKey Linux Virtual Appliance Library

Cannot log into MySQL or PHPmyAdmin using Wordpress appliance default credentials (Solved)

I've downloaded the Wordpress appliance turnkey-wordpress-2009.10-2-hardy-x86.iso and installed it in VMware 7.1 under Windows XP SP3.  As NAT networking is used, I get a IP of 192.168.58.135 which works when viewed in Firefox.

 

The Wordpress appliance page on this website says that the default credentials are: "Webmin, SSH, MySQL, phpMyAdmin: username root, no password."  However, when I hit Webmin or phpMyAdmin, I cannot log in using root with no password as it gets rejected.

 

I have used two other instances of the same appliance for a week without any problems.  I only came across this problem when I tried to write a Wordpress backup script, and it was then that I found out I couldn't log into MySQL, phpMyAdmin or Webmin.

 

I must be doing something very dense, but I can't work out what at the moment :-\

 

Hopefully someone here will be able to help resolve this problem?

 

Thanks.

Jeremy's picture

Passwords are set at install

When using the .iso it can be run live (all data lost on reboot) or installed. If you are running live then you do not require passwords.

If you have installed it, you would have been required to set passwords during install and you will need to use those.

JedMeister - thanks for your

JedMeister - thanks for your advice.  It turns out the problem was the fact my password had a ! in it.

 

I just created a new VM, installed the WP appliance, used just upper & lower case letters as well as numbers in my passwords, and am now able to log into phpMyAdmin & Webmin so all's OK now.


! in password

Seems that this is still a problem, SSH/Webmin work fine, but phpMyAdmin does not

Cannot log in to the MySQL server
 
What is the easiest way to resert the mysql password?

Solved

Somehow the mysql root passw3ord did not set during install (or I forgot it!)

Solution was here (and the ! did not matter)

http://www.turnkeylinux.org/forum/general/20110901/root-mysql-password-startup

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)