TurnKey Linux Virtual Appliance Library

Wordpress and Postfix, "connection refused" on all mail

I have the Wordpress appliance installed, everything is great but all my email from Wordpress is being caught by Postfix. I see this message on the mail in the Postfix queue, "connect to mail.mydomain.com[xx.xxx.xxx.xxx]:25: Connection refused".

I've followed the config instructions but am still getting nowhere. I'm a bit ignorant when it comes to email and Linux, any help would be greatly appritiated.

Thanks, Gabe

Jeremy's picture

Which config instructions?

I'd start at the start and double check network connectivity. Can you ping mail.mydomain.com &/or xxx.xxx.xxx.xxx ok?

intranet

Hi,

Thanks for the reply, I should have mentioned that this was all internal on an intranet site. I realized I needed to set "Send outgoing mail via host" to the local email server IP. Now its working.

Thanks again.

-Gabe


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)