TurnKey Linux Virtual Appliance Library

TurnKey File Server - Can't connect to the appliance via http

Hi,

I just discovered Ubuntu, Virtualbox and Turnkey (amazing)  last week.

I installed virtualbox on my Vita, then Ubuntu, then created one new virtual machine >> install turnkey File Server. 

I followed the instructions of Alfonso Romero's book (excellent one). Everything is fine : got my File server installed but when i tried to access to the server using the IP adress of the  Turnkey Linux Configuration Console, it just doesn't work. It doesn't work either when I use https://fileserver.

So what did I do wrong ? And what should I do to fix this mess ;-)

Thanks in advance for your answer.

Jeremy's picture

Check your network settings in VirtualBox

I'd guess that's your problem. From 'Network Settings' in the VBox manual :

VirtualBox by default enables one virtual network card and selects the "Network Address Translation" (NAT) mode for it.

which is fine for outgoing and general desktop work, but not so good (by default) for incoming connections - what you want for your server. You can set NAT up to port forward (the relevant ports) or you can just change the networking to 'Bridged' and the VM will appear as any other machine on the network. The options for network conections are described in the manual here.

That should fix your access via the IP set with TKL config console. For access via hostname, have a look here and here and see if they help you out.

Failed to bring up eth0

Hi JedMeister and thanks for your prompt answer.

I red your links and selected the 'Bridged'.

I better understand how it works.

Now, when i launch "File Server " (from the hard drive) I have the following massage : no interface are configured.

So i tried to configure it automatically (cause i  don't know how to do it manually) and i got this message : "Failed to bring up eth0". 

Q : what should i do next ?

Thanks for your time.

PS : i am a newbie in networks setttings :-)


Jeremy's picture

Have read through this thread

here and see if anything ther helps. There are some more links to check out within that thread. Keep in mind that some things may not apply to you.

If that's too daunting or doesn't explain enough then feel free to ask more here and I'll try to help. You could also try your luck on TKL irc and see if anyone who can help is about.

If you do post back here It'd be handy to have a little more info about your network. Also knowing whether you are installing from an .iso or VM image may help narrow down possibilities too.

If you do find a solution then it'd be nice to post back here explaining how you fixed it as it may be helpful for others.

JedMeister, thanks for your

JedMeister,

thanks for your amazing support.

Just fixed it by changing the adapter. Very easy.

So, summing it up, i'd say if you have the same issue, start by trying any available adapter.

And i won't say more cause i am really new to networks settings.

Thanks again.

I use virtual box.

I created one new virtual machine. "Linked" it to one ISO file (TK File Server).

I installed File Server on my computer.

Then I launched File Server from my hard drive (this led me to the Network console).

As my IP my network configuration was set up i logged in my server.

The last thing i want to know is when i close the console administration, i go back to one black screen where i am asked one login and one password. Aren't they the same as the ones i use when logging in throuht my browser ?


The last thing i want to know

The last thing i want to know is when i close the console administration, i go back to one black screen where i am asked one login and one password. Aren't they the same as the ones i use when logging in throuht my browser ?

I assumed you tried and you found that is true.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)