TurnKey Linux Virtual Appliance Library

MySQL PHP Data Import greater 8MB

Hello I woud like 80MB over PHP uploaden? Change the PHP.ini but i have time import Problem. Who can my help? Thanks

Anne's picture

Solution

 

Hi,

You need to edit both php.ini and my.cnf.
Then restart PHP and MySQL (or reboot).

If your dump file is really big, use this:
http://www.ozerov.de/bigdump.php

Regards,
Anne

Thanks i'm upload 100MB, wich

Thanks i'm upload 100MB, wich konfig are php.ini and my.cnf?

Can you Post the change from 8MB to 100MB?

 

Thanks M

Anne's picture

Solution

Edit with vi or nano. Don't forget to sudo. But remember, these settings are not recommended for daily use (potential security risk)...

In php.ini:

; Maximum allowed size for uploaded files.
; http:// php.net/upload-max-filesize
upload_max_filesize =
2M

Also in php.ini:

; Maximum size of POST data that PHP will accept.
; http:// php.net/post-max-size
post_max_size = 8M
 
In my.cnf:
[mysqldump]
quick
max_allowed_packet=32M
 
The bold numbers are default.
Jeremy's picture

Good work Anne!

But FYI sudo is not required in TKL appliances as default user account is root (although all processes run under limited accounts).

Thanks for you special

Thanks for you special support!

Liraz Siri's picture

We'll look into changing the defaults

Perhaps 8MB is too small a size for the default upload limit. I'm thinking maybe we should ramp it up to 32MB. The flip side is that I think larger upload limits make DoS (Denial of Service) attacks easier. OTOH, DoS is impossible to stop entirely anyhow.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)