TurnKey Linux Virtual Appliance Library

Unable to launch to Amazon EC2

Hi all.

I’m trying to launch a Joomla appliance to Amazon EC2 using the hub, but I keep getting the error "This region of Amazon EC2 is temporarily out of capacity. Try launching in a different region or wait a few minutes".

The region I’m trying to launch in is us-east-1 (North Virginia), the instance size is m1.small and I’m providing a root password (SSH key-pair, Elastic IP and EBS volume are set to None). This has happened for the last 24 hours, and Amazon service health dashboard indicates no problems (I’m new to Amazon so I don’t know whether this kind of issues usually show up there).

Comments in this forum post suggest than changing the zone would solve the problem (haven’t tried though) but I would really like to launch in that zone because it’s cheaper.

Am I doing something wrong? Do I just have to wait longer?

Thank you very much in advance.

enter 2.0

Liraz Siri's picture

Sorry about that, we weren't expecting this problem

We know about this problem and are trying to find a way around it. We get an error message by e-mail every time a region is over capacity and we've been getting a lot of those error messages associated with your account in the last day or so. Sorry about that and thanks for being so persistent! When I try to create an instance in that region it works, so I think Amazon is reserving it users that have existing assets in that region.

Other users have also been experiencing this problem. An immediate workaround is to launch in another region. If you try later it may resolve itself as soon as Amazon add additional capacity in that region. Or not. We also have another idea for a workaround that involves automatically selecting a different availability zone within that region. Hopefully that will be implemented soon and we can send an update out to all users who have experienced the "over capacity" issue.

Alon Swartz's picture

Should be solved.

The fix Liraz mentioned has just been deployed to the Hub. I discussed it briefly here.

Let us know if it solves the issue for you.

works like a charm now

Problem solved! You guys rock.

Thank you very much Liraz for the quick response and Alon for the quick fix! That's what I call great support.

Cheers.

enter 2.0

PS. sorry guys about the spam, didn't know I was doing it.


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)