TurnKey Linux Virtual Appliance Library

File Server Virtual Appliance - Extplorer fails out of the box

When accessing extlorer on the file server va, i enter my credentials for root and get an access decied.  I go in and change p/w for root on samba, get denied.  set p/w for samba user nobody, get denied or it hands w/ blank p/w.  Any insight how to make this work out of the box?

Jeremy's picture

eXtplorer uses its own user database - not Linux users!

The default login details for eXplorer should be on the appliance page, you then need to set up user accounts. For security you will need to change the default admin account password.

I would strongly suggest that you do not use root for Samba access, set up new user accounts for Samba: create new Linux users then sync Linux users with Samba users - all this easiest done in Webmin. You also need to remember that just like in advanced Windows file sharing there are 2 levels of permissions, file permissions and share permissions. There should be many posts about Samba permission here on the forums, use the seach function (top right corner).

Defaults do not work

I am also installing the FIleserver on 4 seperate boxes. The admin username and password I set up from the beginning does not work. Even if I change the password many times over. Are we missing something?

Jeremy's picture

Which particular password are you referring to?

Assuming you are using the current stable v11.x TKL appliance (and if you're not then go do that), on first boot you should be asked for 2 passwords: The root (Linux admin account) password, the other should be for eXtplorer admin user.

The root password can be used for logging into the local terminal, SSH, SFTP, WebShell (Shell-in-a-box) and Webmin (username: root). The eXplorer password should get you into default eXplorer (username: admin) - although IIRC you use root (or another Linux user) to access the webFTP part of eXtplorer.

Confusion understood.

Hi,

Ok. I had the same problem.

I was expecting that this app also had the users sincronized, so when I create a linux user, he is sincronized to the samba module and also to this app.

Guess I was wrong. That's bad. So I have to create a user in two places. :(

 

Everything else is great!!! Good job.

Rui Gouveia

 

 

Jeremy's picture

eXtplorer batch import can be done apparently

I'm sure I read somewhere on the eXtplorer website that you can batch import users but it's a bit of a hack. The other thing is that you can use FTP mode (which uses Linux users). It'd be nice if you could make that the default but I don't know if that's possible.

Syncing Samba users is pretty easy. One click in Webmin.

yahoo password find

exlelente work tunkey people,  the password for eXtplorer is   "turnkey"

 

thanks

Jeremy's picture

Only with TKL legacy

None of the v11.x appliances have default passwords AFAIK. eXtplorer password is set on firstboot.

Proxmox 2.1's template defaults to turnkey password

I had the same issue after installing TKL File Server using Proxmox 2.1's provided template.
(That is, the one installed directly from the Proxmox admin page: Storage > Contents > Templates button.)

TLK File Server version was 11.3-1 (i386).

When installing via this method, it does not ask for defaut passwords.  Proxmox uses your container password for the root user / ssh access. But not Extplorer.

The default combo for Extplorer was: admin / turnkey
And not: admin / admin.

Never-the-less, I found it pretty useless for my needs.   I found was better to setup samba via Webmin, and use Webmin's file browser (if you really have to) and nevermind Extplorer in the first place.

But whatever you do: Log into Extplorer and changing the default admin password!!!

Jeremy's picture

you need to run firstboot scripts manually

There is currently no way to trigger the firstboot scripts with OVZ templates (ie when 'installing' from PVE WebUI) so you need to run them manually.

This can be done with the 'turnkey-init' command. It allows you to set all default passwords and sets unique SSH keys and random passwords for internal connections between apps (such as MySQL passwords used by Web apps).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)