TurnKey Linux Virtual Appliance Library

LAMP phpMyAdmin and Webmin problem

I downloaded and installed the LAMP appliance to Virtualbox to test out a PHP app.  Everything works, except I can't log in to phpMyAdmin using the root password I set during the initial configuration.  Here are some changes that I made to the default configuration:

  1. set hostname using hostname command
  2. set ServerName in /etc/apache2/httpd.conf

I am also accessing the appliance outside of my firewall using a dyndns.org domain name.  All required ports are forwarded in the firewall.  I am no good with MySQL commandline, hence the need for phpMyAdmin.

The second problem that I am having is with Webmin.  Whenever I create another virtual host using something like port 12323, I can't access the site either inside or outside of my firewall.  Troubleshooting has gotten me nowhere.  I tried setting up the site manually using the phpMyAdmin as a template, but it's no go.  If I temporarily change the phpMyAdmin Document Root to that of the new site, I can access the files just fine.  That tells me it's not a permissions issue.  If I then change the port for the redirected phpMyAdmin to that of the new site, I can access the files just fine.  That tells me it's not a firewall issue.  Only a configuration problem is left but I don't know what it is.  Why wasn't the site working using the automated Webmin way?  Restarting Apache and the virtual machine numerous times hasn't gotten me anywhere.  I also updated Webmin to the latest version after trying all of the above.  I am stuck.

I tried LAMP 11.0rc and

I tried LAMP 11.0rc and didn't have the phpMyAdmin problem.  However, it did have a problem adding additional virtual hosts using Webmin.  I solved the problem by adding the port to the apache2 ports.conf file.


TKLAMP setup of new virtual server thru Webmin

I ran into the same issue.  The setup looked good, but, the server/Apache was not listening to the port that I configured to allow it to distinguish between the different websites.  As David suggested, I modified the /etc/apache2/ports.conf file and added the port entry, which was conspicuously absent...  et Voila! The hello world said hello!  Thanks David.

- Tom

Jeremy's picture

So this is a Webmin bug then?

From what you have said it sounds like it's a Webmin bug. Does that sound fair?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)