TurnKey Linux Virtual Appliance Library

I keep getting nothing but 'eth0' when trying to use dhcp. or static

I keep getting nothing but 'eth0' when trying to use dhcp. or static

and I cannot get it to do anything but say 'eth0' when trying to connect to the network, and it will not allow me to use dhcp or static ip to connect it to the network, and I try pinging it and it says Request Tiimed out, and I need someone to help me.

Jeremy's picture

Please give a little more detail

Where are "getting nothing but 'eth0'"? Is that in Conf Console? Or somewhere else? What have you tried?

I fixed it

I fixed it, it was in Conf Console, but why this happened, is because I had mutiple "auto" interfaces, which it said in the man pages, that I could have mutiple "auto" statements, but when you said "auto" you mean that it is a physical Adapter, which in my case, I only had 1 "physical" network adapter, in my computer. so I removed those entries in the /etc/network/interfaces file and well my computer got hot, and turned off(this is because it is a old computer.), but this was after I removed the mutiple auto interfaces from /etc/network/interfaces file and saved the file, and I turned it back on, and started it back up, and tryed to get a new dhcp ip address, and it didn't say this time, 'eth0' and not let me get a ip address, it worked like normal, but I didn't try to set a static ip address because I usually use dhcp to get a ip address. But thank you for being ready to jump in and help me, And I appreciate you for jumping in and trying to help me in case I did need help.

Jeremy's picture

No worries.

Glad you got it sorted.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)