TurnKey Linux Virtual Appliance Library

PHPMyAdmin in Joomla Lucid

L. Arnold's picture

I was able to manually "overwrite" the Default Joomla Lucid with the Joomla Hardy Files, and I was able to do an sql dump and "execute" in webmin-mysql to update teh Hardy Data Files.  I even got it to start up after I cleared cache on the back end.

I cannot, however, get PHPMyAdmin to start up.  Basically times out.

Contrast to TKLBAM overwrite of Fresh Lucid Joomla Install, with Hardy Joomla Backup.  In that situation I basically killed MYSQL. I tried deleting/renaming the 0 and 1 (/var/lib/mysql) log files as mentioned in InnoDB but no effect on the Joomla Port.

I have done a few "apt-get updates".  I also did a Curl Install to get Joomla to behave properly.

Thoughts on how to get PHPMyAdmin working?  The Webmin-Mysql is fine for doing a batch import without a lot of questions being asked but not for really working with the data much.

thank you for any help,

L. Arnold

Jeremy's picture

I have no idea really

But first thing I would do is check the Apache config (I think phpMyAdmin runs under Apache although perhaps not?) If it's not running under Apache check the config of Lighhtpd - that's what Webmin runs under - or at least it did in the 2009.10-2 release.

Another thing you could try is reinstalling it. Assuming the TKL guys use phpMyAdmin from the official universe repo, off the top of my head it should be:

apt-get install --reinstall phpmyadmin

If I've lead you in the wrong direction and that command doesn't work, just use

apt-get remove phpmyadmin && apt-get install phpmyadmin

That command will work but as it will still use the current config it may not solve all your issues. Double check through webserver configs but if it still doesn't work you may want to purge phpMyAdmin config. Easiest way I know to do that is to:

apt-get --purge remove phpmysql && apt-get install phpmyadmin

If you wish to have phpMyAdmin running on port 12322 again (rather than being <ip-or-hostname>/phpmyadmin as it is by default from memory) you may need to tweak the web server settings.

PS If you are using a VM I would strongly advise you do a snapshot first though so worst case you can easily back-track. Otherwise, perhaps just start a new VM, that way you can compare what you have with a new VM.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)