TurnKey Linux Virtual Appliance Library

Cannot log in to web interface for Wordpress or Torrent appliances

I've installed both the wordpress and torrent appliances, however I am not able to log in to the web interface for either one using the password I supplied during setup. I've tries usernames 'root' and 'admin', blank password, and the password I supplied during install.

Jeremy's picture

Which version are you installing?

The v2009.10-2 appliances generally had default user/password preset, details should be available from the relevant appliance page (WordPress, Torrent Server - scroll down, should be just above the screenshots). The v11.0RC should use these same defaults.

But from the stable v11.0 release there are no more default passwords, they are set on first boot. If you are using the (still as yet officially announced) v11.0 then try resetting the passwords by running the firstboot inithooks again. and as a general rule try to avoid special chacters because they sometimes cause problems.

I'm using v11 RC (there was

I'm using v11 RC (there was no link to download stable 11 as of yesterday?)

try resetting the passwords by running the firstboot inithooks again

I cannot log into the appliance, period. Not through SSH, web interface, anything. The only way I can try a new password is by reinstalling the appliance?

and as a general rule try to avoid special chacters because they sometimes cause problems.

This drastically reduces how secure the appliance is, when you are forced to use 'weak' passwords that do not support special characters. Is there any plan to support special characters?

Jeremy's picture

I suggest redownload and reinstal the appliance

The appliance links have been updated to the v11.0 release (despite the fact that they haven't yet been officially announced).

It may be worth trying to use more complex passwords on the new appliances (passwords go in on first boot now instead of install) and see how it goes. For clarity special characters work in appliances and always have, its just that some people had issues with them if they initially set passwords with special characters. Once installed and setup the user password (for Webmin, SSH, SFTP etc) can then be changed to anything you like via the command line.

I'm not 100% sure why that was, something to do with keyboard mapping on install.

its just that some people had

its just that some people had issues with them if they initially set passwords with special characters

This is still an issue with v11 stable, setting a password initially with special characters does not work at all. However I was able to reset it without reinstalling by changing ro to rw init=/bin/bash in grub menu (single user mode does not work, since it prompts for root password)

It might be worth adding some big shiny notice to new users that special character passwords do not work initially, to save others the headache.

 

EDIT: unfortunately setting the webui password to include special characters does not work either, and since 'admin' is not a unix user (and i'm not familiar with how turnkey saves the pass for that user..), another reinstall of this appliance is in order...

Jeremy's picture

Out of curiosity, are you installing to VM?

I have heard of some people having similar problems with VM environments (I think ESX/ESXi/vSphere)?

Also when you say 'webui' what exactly are you referring to? Different TKL appliances contain different WebUIs, Webmin (accessed via https://<ip_or_hostname>:12321/) is common to all and by default uses the root user account credentials, it should work with whatever password root is regardless of whther it has special chars or not. If that is not the case it'd be good to know so we can work out whether this is an upstream bug or something specific to TKL.

I am unfamilar with the WebUI for the torrent server appliance (although I have dabbled briefly) and I'm not sure what WebUI the WP appliance has. It is possible that it is an upstream limitation. If you could please be more specific about the WebUI you are referring to and which characters in particular it struggles with, again we can start to determine where the problem lays. And as you suggest documentation of these sort of issues needs to be made somewhere obvious.

Alon Swartz's picture

Special characters, single user mode

AFAIK the bugs relating to special characters in passwords have been fixed in 11.0. Please post back if you can confirm otherwise.

Jedmeister raises a good point regarding keyboard mapping which wasn't addressed in 11.0. If anyone can reproduce the issue and offer a solution it will be more than welcome.

BTW, you could reset the root password by booting into single user mode.

Special Characters

I'm not able to SFTP into any of three V11 machines I built today. Everything else appears to work. This thread has me thinking it could be that the root password I specified starts with "$"

I am installing on an ESXi4.0 as a vm. root has access elsewhere, and PW is correct there - only using Filezilla to any of these machines.

Or, did I bork something else up? (I am admittedly n00b to Linux - my experience with Unix was in college 20+ years ago. So please be kind & speak slowly. ;)

Alon Swartz's picture

Special character bugs still relevant

Quick update regarding 11.0.

Since there has been some talk on the issue, I've done a lot of testing and can verify that certain special characters will cause a bug in the way the root password is set on firstboot. Additionally, the following appliances are also affected by a similar bug in their password setting code: bugzilla, domain-controller, ejabberd, torrentserver, vtiger.

The current workaround (yes, I know it kinda sucks) is to not use special characters on firstboot. Once the system has booted you are free to change the passwords.

We consider this a serious bug that somehow slipped through our testing, so we will be patching all appliances and re-releasing them.

Regarding pre-seeding via the Hub, it's more complicated but we will fix that too and upload new AMI's. In the meantime we've updated the Hub to not accept special characters until the new AMI's are available.

Sorry about this folks, and thanks to everyone who reported it.

Affects more appliances

I have the same bug on Wordpress, Moodle & Mediawiki - so it may just be universal.

What defines "special characters?" Would that include numbers, or just things like $, %, &, etc...?

The rest of the appliance seems to work fine - I guess I'm not too worried about reinstalling again because of this bug if I pick a password "compliant" enough.

I'm using these appliances in an ESXi environment in a K12 school district. We lack the kind of funding & engineering to be successful at this installing "the other way." I've never managed to make my Wordpress 3.0 multisite work properly on IIS due to permission errors. Building & maintaining our own Moodle install is beyond what we have resources for.

So thank you for your efforts. Its a good deed that goes beyond "saving me work" and positively affects about 1000 students and teachers who otherwise wouldn't have this opportunity.

Alon Swartz's picture

The setting of the root password affects...

The setting of the root password affects all 11.0 appliances. The specific appliances I mentioned are also affected relating to the applications 'admin' passwords.

Regarding special characters, I mean the $ ! ( ` ones...

Just use alphanumeric passwords on firstboot, you can change them later to what ever you want the conventional way - no need to build the stack yourself.

I have the same problem here

I can login to: MlDonkey at port 12322, webshell at 12320, webmin at 12321 and explorer but cannot to web-gmui at 12323. Reinstalled system 3 tmes with different credentials and still the same. :(

Sorry, forgot to inform: it

Sorry, forgot to inform: it is Torrent Server Appliance 11

Can't believe that :(

Ju installed 11.1 appliance and still the same. The password is: qw. Couldn't be more "special character" friendly :(.

The login to web-gmui  is: root , yes ?

Jeremy's picture

I think the default username is 'admin'

Give that a go asap and if it still doesn't work then please report back and I'll double check and if it's a problem we'll log a bug.

No success :(

tried: root, admin, turnkey  - no way. I still can login to ALL OTHER turnkey pages without problem.

Jeremy's picture

Just checked it and no issues here!?

I just downloaded and installed the v11.0 release of the torrent appliance and it works fine for me.

I tried it with a few different passwords, including special characters and it worked fine for all of the relevant interfaces (including MLDonkey & Web-GMUI - both using username: admin password: as defined on install).

So not sure what your issue is here? If you were having problems with logging into other interfaces I would suspect a keyboard/keyboard mapping issue but as you said the others were ok, I'm not really sure.

FYI if you can log in (to root via Shell-in-a-box, SSH or local console) you can reset the passwords by making the appliance ask again on reboot by editing the appropriate line in /etc/defaults/inithooks eg:

nano /etc/defaults/inithooks

Look for the line that says something about first boot, change the 'false' to 'true'. Sorry for my vague directions but it should be pretty obvious (in mine there were only 3 lines and it was the last one.

Alon Swartz's picture

Execute torrentserver inithooks directly

I tested all appliances with special chars before uploading, so the special char bugs should be squashed. 

Btw, you can execute the torrentserver inithook directly instead of re-running all inithooks as follows (this goes for all appliances as well):

/usr/lib/inithooks/bin/torrentserver.py

"If you were having problems

"If you were having problems with logging into other interfaces" - no I have not. I had never problems to log to other interfaces only to web-gmui - this is strange. The machine I am testing tunkey on is pretty common old Acer laptop with american qwerty keyboard.

Where exactly is password for

Where exactly is password for web-gmui stored ?

I just looked

I just looked into:

/usr/local/bin/mldonkey-config

 

# configure mldonkey                                                                                                                                                                                           CONF=/var/lib/mldonkey/users.ini                                                                                                                                                                               sed -i "s|user_pass =\(.*\)|user_pass = \"$MD4_HASH\"|" $CONF                                                                                                                                                                                                                                                                                                                                                                 # configure webgmui                                                                                                                                                                                            CONF=/usr/local/lib/webgmui/webclients.json                                                                                                                                                                    sed -i "s|\"password\(.*\)|\"password\" : \"$PASSWORD\"|" $CONF                                                                                                                                                                                                                                                                                                                                                               CONF=/usr/local/lib/webgmui/webusers.json                                                                                                                                                                      sed -i "s|\"password\(.*\)|\"password\" : \"$MD5_HASH\",|" $CONF                                                                                                                                                                                                                                                                                                                                                              # configure extplorer users                                                                                                                                                                                    CONF=/var/www/extplorer/config/.htusers.php                                                                                                                                                                    sed -i "s|\"admin\",\"\(.*\)\",\"/|\"admin\",\"$MD5_HASH\",\"/|" $CONF                                                                                                                                         sed -i "s|\"guest\",\"\(.*\)\",\"/|\"guest\",\"$MD5_HASH\",\"/|" $CONF

What is the difference between webclints and webusers for eb-gmui ?

so what's the username?

I just installed the latest VM version of Turnkey Wordpress appliance on VirtualBox. I understand from above posts my login should be the username and password I set up on first boot. But I wasn't asked for a username. I tried entering the admin email address I set up but that didn't work - although I don't seem to be able to type an @ sign at the moment (I could the first time I tried it...)

 

Ta.

Jeremy's picture

What are you logging into?

It depends what part you are trying to log into.

For local terminal, SSH, SFTP, Webmin & WebShell (Shell-in-a-box):
Username: root
Password: <set at firstboot>

For most other WebUI logins should be:
Username: admin (or check the default admin username of the specific software, ie in this case WordPress)
Password: <set at firstboot>

Let me know how you go with it.

I'm logging into the

I'm logging into the Wordpress Application in VirtualBox. Done it, thanks! Username root, password <set at first login>.

Now what?

OK, so I logged in and am faced with a command line. The only suggestion of what to do next I could find was this at http://virtualboximages.com/WordPress+2.9.2+Virtual+Appliance http://virtualboximages.com/WordPress+2.9.2+Virtual+Appliance

1. Create a Virtual Machine in VirtualBox or VMWare and attach to the WordPerfect 2.9.2 VDI/VMDK
2. Ensure that you have the Networking in VirtualBox set to Bridged network
3. Start the Virtual Applicance
4. At the prompt login as 'adminuser' with the password 'adminuser'
5. At the prompt enter the command 'ifconfig' to find the ip address of the Virtual Applicance and record the address. You will see an a local address for either eth2 or eth1 in the network range.
6. Open a browser on a computer on the local network and open 'http://yourserveraddess/wordpress/wp-admin/install.php' replacing yourserveraddess with the address from step 5.
7. Note the password given to you.
8. The install script should then send you to the login page. Sign in with the username admin and the password generated during the installation. You can then click on 'Profile' to change the password.
9. Enjoy your new WordPress Virtual Appliance

 

Unfortunately the admin.php page does not seem to exist. So I have a lovely Turnkey Wordpress account in my browser but none in my VirtualBox. Sigh.

 

Sorry for being so clueless but I'm self-learning web design and have to start somewhere!

Jeremy's picture

Perhaps you misunderstand the concept of these appliances

TKL appliances are server appliances, designed generally to be run headlessly or virtualised and administered remotely, hence no GUI.

If you want to administer your Ubuntu-based Turnkey Linux server then command line is the go - either via SSH or Webshell (Shell-in-a-box). If you find that daunting then Webmin can be quite handy. The Wordpress component itself is administered via it's own WebUI. All of these services/interfaces (except for SSH) are accessed via a web browser from another machine (the host machine or another PC on your LAN when using 'bridged' networking under VBox). The TKL confconsole (the default blue start up screen in the TKL terminal) will inform you of the IP address of your appliance and the relevant ports to include. Generally browsing to http://<applianceIP> will load up a default TKL start screen with links to the other bits, otherwise type them in manually.

FYI

I'm having the same issues with Vtiger CRM Appliance. I can't log in I tried reinstalling but it dosen't work. I tried it on VMware ESXi and Amazon EC2. Same thing on both instances. No access.

Come on guys we need this stuff !!!

Jeremy's picture

If you want some help you'll need to give a little more info

When you say you can't login, what are you trying to log into? Webmin? vTiger? SSH/SFTP? What have you tried already? Do you have network connectivity? Can you ping the appliance ok?

For the record, the default username for Webmin, SSH, SFTP and Webshell (Shell-in-a-box) is root & for vTiger is admin (passwords set at first boot for ISO/VM; pre-launch via the Hub for AWS).

Jeremy,   thanks for

Jeremy,

 

thanks for clarifying the concept. So I think what you're saying is that I treat my Wordpress virtual machine as I would an external web hosting server and don't do anything directly on it, but upload and download using a browser on my local computer and the IP address from ifconfig. Is that correct?

Jeremy's picture

That's it!

You can do everything through your web browser if you want although personally I prefer to use client software for file tranfers in & out and shell access. On Windows 2 programs I would recommend are Filezilla (for SFTP file transfer) and PuTTY (SSH client).

Vtiger is working

I reinstalled it on my VMware ESXi box and it worked with the admin username. Thanks for all the help guys. 

http://www.turnkeylinux.org/forum/support/20110314/cant-log-vtiger

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)