TurnKey Linux Virtual Appliance Library

Cannot Login - Bridged Networking Problem

Hi iam trying to use the new turnkey drupal6-11.0rc ISO with virtualbox in windows xp pro sp3. Its installed, bridged networking is set and its not working on my wireless or cable ethernet. I cannot get a ip address from dhcp its coming back lease failed etc eth0, and as result cannot access the login screens from my hosts browser

I have dhcp allowed on the hardware router. I don'nt see any firewall requests for the virtual machine going out.

I have went over the "netsh bridge show adaptor" which is coming back command not found, this is to allow promiscuous mode or check if its enabled with out which the virtualbox bridged networking driver would not work. Reference  http://www.virtualbox.org/ticket/735 (Vbox could have fixed this now but I think sp3 has remove the ability to change promiscuous mode on network adaptors)

Nat is gettting a dhcp ip address in the vm

I have tried setting a static ip for bridged networking but it didnt work I may have done it wrong though.

I could do the bridged networking for virtualbox the old way and bridge them by right clicking in network connections (xp) or port forward nat (Reference http://www.virtualbox.org/manual/ch06.html#natforward) Could I still login using an ip address on the host or it all ports on the local host from then on, how would you log into the main login which doesnt use a special port other than probally port 80 I think

I am only after learning the past few days so please explain it very very simply to me. Thanks guys

Jeremy's picture

Should just work with Networking set to bridged

I use VBox 3.2.0 on Ubuntu 10.04 and 3.2.(whatever its up to) in Win XP and find it networks fine with the LAN using 'bridged' networking, no hacks etc required. By default the appliance should then just pick up an adress from your DHCP (although if you plan to use it a bit I'd set a static one - I'd let DHCP run first though).

Perhaps you need to put an exception for VBox in your filewall though? I don't recall it was that long ago I set it up.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)