TurnKey Linux Virtual Appliance Library

redmine inaccessible remotely (from Internet)

I installed the latest turnkey redmine appliance (2009.10-2) and seems to be working well on the local network. However, when I try to access the web page remotely (from the Internet), I do not get a response from the redmine server. Remote access seems to be working OK since I can access the Webmin interface remotely (https, port 12321) and I can access the mercurial interface (http, port 8080), I just don't get a response from the redmine interface (http port 80 or https port 443). The server is configured with a public static IP, and I can login to the Webmin interface, so it appears that the network portion of the server is setup properly. I am not too familiar with the integration into apache and which settings might prevent the remote access. Does anyone have any idea of which settings might affect this problem? Has anyone else setup a turnkey redmine server with a public static IP (for remote workers to access the redmine server)?
Alon Swartz's picture

11.0 is the latest

TurnKey Redmine 11.0 is the latest version (based on Lucid). Version 2009.10-2 is the legacy version (based on Hardy). We'll be removing the legacy versions download links as soon as we announce the 11.0 release (which will happen once the VM builds are ready).

With regards to remote access, how did you set it up? Are you using reverse NAT (ie. PAT - port address forwarding)? If so, your router might be listening itself on port 80/443 which would cause issues.

Jeremy's picture

ISPs sometimes block 25, 80 & 443?

Considering that you can access all content via the LAN and some of the content offsite I would definately guess local routing issues or ISP.

To see whether there is something else listening or it is blocked do an external port scan from a PC on the same LAN as your appliance. You can use something like SheildsUP and test the state of specific ports or a generic range. If its blocked I'd enquire with your ISP whether they are blocing you.

Yes, looks like ISP is blocking 80 and 443

Thanks for the tip.  I setup the apache config to listen on another (less common) port and was able to access externally.  Thanks again.

Where can I change the ports

Where can I change the ports that Redmine listens on? I tried changing the ports.config file under /etc/apache2/ports.config. That did not seem to work. I need to change the porst as there is a conflict on my network. Any help is appreciated!

 

Thanks!

 

James Ott, jr

jott@federalradio.net

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)