TurnKey Linux Virtual Appliance Library

tklbam ntpdate so servers suitable found

Hi,

i'm trying to use tklbam. tklbam-init with key was done. after tklbam-backup is called an error is displayed, because of ntpdate errors. if i call ntpdate -u pool.ntp.org, the answer is always that not suitable server for synchronisation could be found. Any hint how to proceed beyond this point or avoid this error?

Info: turnkey-rails is running inside virtualbox. internet connection is available and working.

Alon Swartz's picture

NTP outgoing blocked?

Make sure that your host system or router/firewall isn't blocking outbound NTP (UDP 123). Try disabling your firewall if you have one and see if that solves the problem. You can find more information on troubleshooting NTP here (I'd start with the 9.8 Check the NTP port section).

firewall blocks

Seems to be true. I have to check how i could use the host server time instead, because firewall rules cannot be changed/accessed.

Thru the XP command "w32tm /monitor" i could find some ip addresses which are working. Using one of them inside the Turnkey file /etc/tklbam/hooks.d/fixclock instead of pool.ntp.org.

Now tklbam-backup just works.

thor42

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)