TurnKey Linux Virtual Appliance Library

Password bug in the "First boot configuration" procedure

Hi, I found a bug in the "First boot configuration" procedure, while setting password.

If you choose a password with at least a "$" inside, when you try to login after the installation is completed, it does not work correctly. I first though it was a keyboard related issue, but if I type the $ character (SHIFT + 4 on my italian keyboard) inside previous not masked fields, I can see the $ character typed correctly. I tested the LAMP and the RedMine appliance, and they both have the same issue. 

To reproduce the bug, try using a password like "lamp.$$01": when you reboot you will not be able to login correctly. Try using "lamp.4401", with exactly the same parameters used for previous installation, and everythings goes fine.

Don't now if it's helpful, but I use VirtualBox 4.0.0 on Windows 7 64 bit, and I chose to apply security updates at the end of the installation.

Alon Swartz's picture

Thanks for taking the time to report this issue.

It's actually already been reported, see my comment for details. I've already solved the special-character bugs, and am in the process of rebuilding all 11.0 ISO's and Amazon EC2 AMI's. I'm also batching the VMDK and OVF builds at the same time, which will bring us to TurnKey 11.1

The TurnKey 11.1 builds should be available for download from sourceforge later today/tomorrow, and we'll be officially announcing the release next week.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)