TurnKey Linux Virtual Appliance Library

Mediawiki, blocking unauthorised reading...

We want to allow just 5 people to access our internal website and block all unauthorised viewing and account creations.

We tried editing the Localsettings.php file

# Anonymous users can't create pages

$wgGroupPermissions['*']['createpage'] = false;

# Only users with accounts four days old or older can create pages # Requires MW 1.6 or higher. $wgGroupPermissions['*' ]['createpage'] = false;

$wgGroupPermissions['user' ]['createpage'] = false;

$wgGroupPermissions['autoconfirmed']['createpage'] = true;

But the website crashed, as main page could not be accessed after that.

Please advice, how can we achieve unauthorosed reads?

regards

Anth :-)

 

 

 

Jeremy's picture

Did you restart webserver after config changes?

AFAIK you need to restart the Webserver service for the settings to be applied (although I could be wrong?).

/etc/init.d/apache2 restart

Should work on both the old v2009.x or the new v11.x (I don't think apache has an upstart script?)

Thank You!! It worked!!

Thank You!! It worked!! Thanks a TON!

Site is supposed to be for 1 department use only. So we didn't want others to see their confidential contents!!

smiley


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)