TurnKey Linux Virtual Appliance Library

Turnkey Magento: Magento Domain Set up

Love Love Love that Magento is an appliance now!  Just have 1 nagging problem.

Going thru the install I get to "Enter the domain to serve Magento."

Does not matter if i input a IP address or anything else (i.e idontgetit.com),

Once it finishes installing I type the http://<ipaddress> in IE or Firefox and it does not load Magento

I can access webmin and all else but not Magento or Magento admin.  The IP address is trying to resolve to whatever I have input into the Magento Domain during setup.

What am I not understanding here?

Alon Swartz's picture

You're not missing anything.

Magento requires a domain name (as does a couple of other appliances) to serve the application. If you don't have a domain name to associate with the appliance (DNS A or CNAME record), and just want to test it locally, you can update you /etc/hosts (or windows equivalent) like so:

APPLIANCE_IP DOMAIN

for example:
192.168.0.1 shop.example.com

That Fixed it

Thanks,  That fixed the problem.

I had some experience with the DNS A record in the past,  but had a time trying to find it again

 

FYI to those needing this help in the future:

if you are using windows

Explore C - Windows - System32 - Drivers - etc

Click on the hosts file and open it with notepad and add in the new record on the bottom

<you appliance ip address>   <whateverunamed your domain.com>

and save the file.

Confused

Hey guys,

I'm new to most of this stuff too, so thanks for reading and helping with this.

I launched a Magento instance and confirmed that it installed correctly, and used shop.weblogic.co as the domain name. 

Next steps I took:

  1. Changed a CNAME record: shop > 184.73.65.221
  2. Changed an A name record: shop > 184.73.65.221
  3. Went into my laptops (Windows 7) drivers/etc and added # 184.73.65.221 shop.weblogic.co.

I guess I'm most confused about the third step. How does changing one of my system files on my machine make any difference to what happens on the Net?

Also, Mageneto is nowhere to be found. Navigate to shop.weblogic.co and you'll see the exact same thing as weblogic.co no matter what you click on. Also, 184.73.65.221 brings you to shop.weblogic.co, but again, look at weblogic.co - it's all the same.

Thanks for your time, guys!

T

Jeremy's picture

Adding an entry to hosts only works locally

It is useful for testing when you need to use an FQDN but don't have an inhouse DNS server. But that is about the extent of it.

To have your site available to others from the internet you need to have your DNS records set up (like it sounds you have - although it's not quite how I'd do it...). I'm certainly no DNS pro or anything but by my understanding; assuming that you want your main webserver to be weblogic.co but you also want www.weblogic.co to resolve to weblogic.co and shop.weblogic.co resolving to a different server (and IP), this is how I'd do it.

#A records
weblogic.co. IN A x.x.x.x #whatever the ip of your webserver is
shop.weblogic.co. IN A 184.73.65.221 #assuming that's the IP of your Magento instance

#CNAME records
www.weblogic.co. IN CNAME weblogic.co

IIRC A records are your main DNS records and CNAME records are sort of like aliases of A records. Make sure you don't have any wildcard entries (ie *.weblogic.co - perhaps that is the root of your current problem?). Also it may take a little while for the DNS to propagate.

I can see clearly!

That clears it all up, thanks. I DO have a wildcard record - I'll delete that and see what happens. 

For both my CNAME and A name records, my hosting provider only gives me two boxes to work with: "hosts" and "points to" (see attatched). Did I set it up correctly? (It doesn't allow me to write in a host of "shop.weblogic.co"; it automatically took out the ".weblogic.co" part when I saved it, rendering just the word "shop" as my host).

Same thing for CNAME. Did I set this up right?

Thanks!

T

Jeremy's picture

Ok

Then I guess it's probably the wildcard entry that's causing issues. Otherwise all looks fine (although you shouldn't need your 'shop' CNAME entry - but it's not doing any harm...)

L. Arnold's picture

Related Issue..

2 Subjects: 

1:  I lost the "Name of my Appliance" somehow on the Blue Console Screen.  Host and Hosts do have some names (etc/hosts)

2: I have been working on setting up "multi domain" hosting with Magento and it seems I am getting closer:

Looks like .htaccess needs to be modified in Magento to make this work  (but perhaps it is the Virtual Host Solution that would be better)

I would like to do the VirtualHost solution outlined in the first link (but I don't know where to put the code - apache or magento).   I have actually gotten "close" on the second (discussed alternative) modifying .htaccess AND index.php, but I would rather just update a host file and get Magento to respond.

Somwhat of a mishmash of issues between TKL/Apache and Magento.  Sorry about that, but thanks for any help/guidance.

L. Arnold

Jeremy's picture

Not sure about #1

But #2; I am guessing that they mean the vhosts/sites conf files that are used by apache. I'd try looking in /etc/apache2/sites-enabled (to check which ones are enabled) and then edit the corresponding file in /etc/apache2/sites-available (the files in sites-enabled should just be simlinks to the corresponing files in sites-available). Hopefully thats it.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)