TurnKey Linux Virtual Appliance Library

Domain Controller where is SAMBA installed

I am trying to upgrade SAMBA to v4 so i can add my win7 pc's into the Domain but they need AD support 

 

I have installed SAMBA 4 

but the default SAMBA is still lurking somewhere and for the hell of my I can not find it 

 

/usr/local/samba

is where my v4 is 

 

smbclient --version

proves that the old version is somewhere 

 

/usr/local/samba/smbclient --version

Proves that my Version 4 is also their 

 

I used this guide for installing samba4 

http://wiki.samba.org/index.php/Samba4/HOWTO#Step_1:_Download_Samba4

Jeremy's picture

Apparently Samba4 in Ubuntu repos works ok

So the easiest way to set up Samba4 would be to first uninstall Samba3

apt-get remove samba

followed by installing Samba4

apt-get update
apt-get install samba4

I don't think Webmin samba module will work with Samba4, but maybe? If not you'll need to configue Samba4 manually via its conf file (not sure but would guess you'll find that in /etc/samba4 or something like that).

No actually you would find the conf file somewhere else

No actually you would find the conf file somewhere else like in like in /usr/local/samba/etc

if you installed samba4 from git and installed it, and everything it says in the samba4howto.

so any idea where the

so any idea where the original samba was located so i can reinstall over top ?

 

I will give the uninstall a go any how .. just wish i could work out where the darn thing lives 

 

SAMBA4 is working as all its settings are added during install .. its just a matter of getting 4 running and not 3 ... 

Check your sbin directory, and other directorys like this

Check your sbin directory, and other directorys like this and look for smb, etc.

smb is the samba 3 server executable

Jeremy's picture

You shouldn't install 'over the top'.

As Samba3 is installed by package management and you have installed Samba4 from upstream git repo my understanding is that it is 'naughty' to install to filesystem areas maintained by package management (ie apt). I'm not really sure even what you would acheive by installing 'over the top' anyway.

Also thanks for stepping in Timothy, glad there's someone here that knows a bit about this. Samba4 is obviously the future and I look forward to having a play with it sometime when I get a chance. It would be great if someone were to look at building a TKLPatch for a Samba4 based PDC. Perhaps I will?

where is samba installed

If you are just getting started...

I would just run your package manager (synaptic on ubuntu) and search for "samba"

Remove any installed "samba" apps.

then use synaptic again search for "samba4" and install it since the previous samba v3 should have

been removed.

If you have done alot of configuration already then why not just 'find' to search for samba

sudo find / -name samba -print

that should at least point you to where you have the old version.

Jeremy's picture

Advice does not completely apply to TKL

As TKL does not have a GUI, synaptic is not available. By default TKL uses apt.

To reiterate myself; remove the current Samba (3):

apt-get remove samba

Or if you wish to get rid of all the config files and the Webmin module too use this instead:

apt-get remove --purge samba webmin-samba

Then to install Samba4 (but as I think I said earlier, you may be better using a newer version as it seems you already have):

apt-get update
apt-get install samba4

SAMBA4 not Accesible from Windows Admin tools

I have installed SAMBA from the source and it worked for several days. I have installed Domain admin tools downloaded from Microsoft and installed on XP System. It has worked fine and I use to administer users from the same. From past few days I am not using the XP amin tool and now when I try to use it from XP, is giving error saying that It cannot connect to domain controller and the user administration can be done for local users.

any suggestions on this.

Thanks in advance for your help.

 

Regards
Spicy.

Jeremy's picture

I recently read about that

I can't recall what the fix is (and a quick search failed to locate the page I remember reading), but apparently it's because of a missing DNS record. You need a special DNS record so that Windows knows where the DC is. If you have a Windows DC then it automatically takes care of that for you, when using Samba you need to configure that manually yourself. If you work it out, be great if you could post back.

Try this

Try this link..

http://admingeeks.blogspot.com

 

complete installation step by step explained.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)