TurnKey Linux Virtual Appliance Library

Unable to logon to SFTP

Hello Everyone,
I'm new to Turnkey-Fileserver and have to admit that I have also only a limited knowledge of LINUX.
 

I installed Turnakey yesterday, created new users and a group, assigned the user to a home directory
but have no luck to have those people using SFTP. I allways get the error message "authentication failed" whenever I try to open a SFTP session as one of the user. SFTP works for root.

Any ideas?

Thank you in advance for your help on this matter.

Roger

Jeremy's picture

How are you creating users?

SFTP uses Linux users to authenticate. Probably the easiest way for a Linux newb is to use Webmin (look for Users & Groups - IIRC you can find it in the far left or second from the left top menu dropdown).

With the Fileserver appliance, there are also Samba users (used for Samba/Windows file sharing). Samba users can be fairly easily be synced with Linux users.

And then there is also eXtplorer which has it's own user database again (unless you use the SFTP part - is that perhaps where you are going wrong?)

Be aware that if you wish to limit what users can do/access/break then for simplicity it may be easier to use either eXtplorer and/or Samba for file access. You can lock SFTP down but it will be a little more involved. By default Linux users will be able to log in to a shell (eg SSH) and will have file system wide read permissions.

Hi Jeremy, Thank you for

Hi Jeremy,
Thank you for your quick reply.
I think that I created the user at the correct location and I also imported them to SAMBA.
All user have a pre encrypted password and use the standard shell bin/sh so far..
The additional user database for eXtplorer my be the reason that I'm also unable to logon there...

Do I have to put the user into specific groups to allow the logon through SFTP, please?
Any ideas??

 

Regards,

 

Roger


Jeremy's picture

If you are using Linux users, AFAIK SFTP should just work...

Although TBH I've never actually done it. I always just access SFTP as root and use Samba/Win shares for other (unprivelged) users. For me that avoids having to further lockdown and limit SFTP and SSH access for anyone other than myself. It sounds as though you have a different usage scenario and that may not work for you?

If you are sure you have set them up right and networking is working fine (can you access SFTP ok using the root account?) then I'm not sure. Perhaps try logging off and then back in again (or even a reboot?)

Unable to use SFTP

Jeremy-

thank you again for your response.

The reason for me to use TBH is htat I would like to provide a fast fileserver solution for the Marketing people within our European locations as they complain about performance issues with our SharePoint server that is locate in the US. The latency and the bandwidth between Europe and the USA is allways a big trouble maker. It would be ideal if I could open up the SFTP access for customer in future to allow a fast and reliable way to exchange Marketing related files like big picture and documents.
 

SFTP work fine for the root account and I did several reboot without beeing able to have users logging. Can you help me perhaps with some information on how to setup / configure eXtplorer so that user can you this way to share files?

Regards,

 

Roger


Jeremy's picture

Hmm, sounds like you are doing everything right!

So I'm not sure what's happening. I've got a fair bit of stuff on just at the minute and don't have time to do any testing right now, but I will endeavour to do this sometime soon for you so we can try to resolve this issue. If I'm not back within the next few days with a post, please either bump this thread or message me directly (you can use the contact form on my profile page). 

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)