TurnKey Linux Virtual Appliance Library

TKL fileserver unable to access share from windows

ryan roberts's picture

Hello all,

I am new to TKL Fileserver. Please point me to documentation as I might have missed it when searching the site and the forum here. I am stuck at this point and not sure what else I need to do.

My Problem: I have TKL Fileserver installed and setup with a Raid 5 array with EXT3 file format and mounted to /TEX

This all works ok. TKL Fileserver is setup and joined to an Active Directory Domain and setup to validate the users from the Active Directory Controller. I have set the password server. TKL Fileserver is visible on the network and I can open the share but when trying to put files on the share I get “You need permission to access this share”. Not sure what I am missing. I have setup the share to allow guest read/write just in case and still get this error. I have made sure to setup the sync for samba/Unix users and vice versa. I have verified that the users from UNIX exist in the samba users. I have made sure that the smb.conf file shows the realm which is set to the domain, I made sure to give all users read/write access to the share.

Now one of the default shares that was setup users are able to read/write to this share but this share is on the small primary hard drive and I need the Raid 5 array to be where users store files. Plus at this point I thought it might have had something to do with the EXT3 file system, so I un-mounted the Raid 5 and reformatted it to EXT4 but now I can’t remount the Raid 5, I now get an error about wrong file system type being on the drive, so now I am completely stuck on what to do.

Any one helping is much appreciated.

Jeremy's picture

Documentation is somewhat lacking

Documentation is currently a TKL weaknesses. There is a lot of info hidden in the forums but unfortunately clearly laid out docs don't really exist yet (work in progress, although progress is slow).

Filesystem shouldn't really matter (ext3 or 4 should do the job AFAIK). I suspect your problem with ext4 may be the fstab entry (still expecting ext3). If you keep in mind that TKL v11.x is based on Ubuntu 10.04 you should find plenty of relevant info via Ubuntu forums/docs, or even google.

As for your shares, it sounds like you've done everything pretty much right. Just double check Linux user file permissions, as well as Samba user share permissions. Also remember you need to restart Samba after adjusting settings.

ryan roberts's picture

Thank you for the quick

Thank you for the quick response, i have remade the filesystem to ext3 and was able to remount it, i have checked the permissions for the samba and linux users and everything from what i can tell is ok but when i view the connections to the fileserver i see my username attached and i see under where it says "open files" i am getting "/tex/. (DENY_NONE)" listed under there...any suggestions on this one?

Jeremy's picture

Sorry mate

Short of trying to recreate your situation and doing more troubleshooting myself (which I haven't currently got time for sorry) I can't really be of any more help to you. I have only had limited experience with the Fileserver appliance. I do have it running at home, but it is a pretty simple setup and it all just works with minor config.

Let's hope someone who has had more experience with this appliance can come along and help.

Chris Musty's picture

Hopefully my experience will help you

I struggled with this for a while also.

Firstly I made sure network discovery was enabled in Win 7 - kind painful

I ended up manually editing the config file (option under servers>samba>edit config or if you are used to it you can access via ssh and edit /etc/samba/config.somethingorother)

Just create a new share and modify samba config similarly

(warning this will leave you with zero security! Anyone can change files without a password)

 

---------------------------------------
[global]
netbios name = FileServer
netbios aliases = FileServer
server string = FileServer
delete readonly = yes
read only = no
writable = yes
workgroup = Workgroup
guest ok = Yes
public = yes
security = share
max log size = 1000
wins support = true
[CDrive]
path = /srv/CDrive
----------------------------------------

Chris Musty

Director

Specialised Technologies

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)